• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

USB external dont seem to be working

Sparky83

Active Member
Sparky83 said:
I've got a green power led lit up but doesn't show on my pc?

Any thoughts?

Was used as my mac auto back up, will need reformatting I guess but I can't if I can't see it
 

paulktreg

Active Member
What version of Windows are you running?
 

paulktreg

Active Member
Can you see the HDD in Control Panel > System & Security > Admin Tools > Computer Management > Disk Management?
 

paulktreg

Active Member
Driver issue? Are your motherboard USB drivers installed/up to date?
 

mdbarber

Active Member
the detection seems to imply the device is reporting correctly until a certain point, can you check the drive on another machine, or at least uninstall via device manager then unplug drive usb and power off PC and drive.
restart both and re attach the usb cable watching for any errors in install.
If its detected as an unknown device this time you will need to power cycle again, this time unplugging the PC from the mains.
Otherwise,, sounds like it may be a drive failure..
 

Sparky83

Active Member
I'll have to have a go at the following later on. Strange that it may have failed now, as it was my mac back up until I sold it last week and all I've done is plug it in to my pc
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom