Urgent help needed with hook up!

dasmith

Active Member
Guys, ive set up my amp(Onkyo 508) with the Bluray, Sky HD & TV. I've got HDMI from Bluray to amp, then HDMI from amp to TV. Ive got HDMI from Sky HD to TV with Optical to the amp. But on the front display on the amp when watching a film only PCM is being displayed when Wall-E and Iron Man 1 are played, surely it should display either DTS 5.1 or Dolby True HD?

Or am i missing something or connected wrong? Its doing my head in, any help would be gratefully received. Mods ive also posted in owners forum but thought more would be in here to get quicker help.

Thanks
 

Dazzor

Well-known Member
Your blu-ray isn't an older PS3 is it? I only ask as they are not capable of sending bitstream over HDMI...so any AVR will be seeing a decoded LPCM signal.


Also, shouldn't it be both HDMI and Optical going into your AVR from Sky, and then just one HDMI to your TV...as opposed to HDMI from Sky HD to TV with Optical to the amp?:confused:
 

PSM1

Distinguished Member
There is no need to have the HDMI from Sky to the reciever so can have HDMI to TV and optical to amp if you want.
 

dasmith

Active Member
Guys thanks for the replies so far. The Bluray player is a Sony BDP-S350 and not a PS3.

I have set the audio on the Bluray to recognise HDMI.

I really cant get my head round it, my older amp, a Sony, used to show what speakers were connected and light up when playing in 5.1, but with this i cant really tell whats happening. What should be in the display when a Bluray is playing?? Please anyone!
 

Dazzor

Well-known Member
There is no need to have the HDMI from Sky to the reciever so can have HDMI to TV and optical to amp if you want.
Not ideal though is it?

Surely it's preferable to have just one HMDI going into your TV, if for no other reason than circumventing the hassle of toggling between AV-inputs on your TV:confused: (I guess a Harmony or similar would get round this though)

My Z7 also does a nice job of making sure the picture always fits in a 16:9 ratio...better than my pio was doing it direct to my SKY HD box anyway. ;)
 

Dazzor

Well-known Member
Guys thanks for the replies so far. The Bluray player is a Sony BDP-S350 and not a PS3.

I have set the audio on the Bluray to recognise HDMI.

I really cant get my head round it, my older amp, a Sony, used to show what speakers were connected and light up when playing in 5.1, but with this i cant really tell whats happening. What should be in the display when a Bluray is playing?? Please anyone!
On my Sony S370 there's a setting called "HD audio mix"....there are two options.."auto" and "off"......select "off" in order to send a bitstream signal.

On my set-up this allows my AVR to do the decoding and so my AVR displays the relevant HD audio such a "Dolby True HD"

Not sure how similar your Sony BDP is, but hope this helps

Darren
 

dasmith

Active Member
On my Sony S370 there's a setting called "HD audio mix"....there are two options.."auto" and "off"......select "off" in order to send a bitstream signal.

On my set-up this allows my AVR to do the decoding and so my AVR displays the relevant HD audio such a "Dolby True HD"

Not sure how similar your Sony BDP is, but hope this helps

Darren
Bingo!! Excellent Darren thank you for that, i had something similar on the 350 so did as you said and now Iron Man is showing as playing in True HD. Going to test the other discs tomorrow, but once again thanks a lot. Can sleep happy now.
 

Dazzor

Well-known Member
Bingo!! Excellent Darren thank you for that, i had something similar on the 350 so did as you said and now Iron Man is showing as playing in True HD. Going to test the other discs tomorrow, but once again thanks a lot. Can sleep happy now.
Excellent!

Enjoy:smashin:
 
Top Bottom