updating ipod touch software

ianlecompte

Active Member
hi, ive just been given an ipod touch 1st gen with 2.2.1 software, when trying to download apps most tell me that i need ios 3 or 4 etc. when i connect to my itunes thingy and try to update it tells me that i have the latest software. I'm really confused, surely there is a way to sort this? My daughter wants to play games on this but cant , is it that old that all apps now only work on newer versions?
I hope this all makes sense, thanks for any help recieved.
Ian
 

next010

Distinguished Member
Back then iPod touch users had to pay for the update so that's probably why your only seeing iOS 2, you will have to purchase the iOS 3 update, no further updates were released after that so iOS 3.1 is as far as it goes.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom