Updated Radeon software to adrenaline - killed it!

JimmyMac

Distinguished Member
I've a pcspecialist laptop, its about 7 years old now running switchable graphics with and 8870M in there

Didn't realise just how long it had been since the last time I updated the radeon software, so much so that I hadn't heard of adrenaline so when I found out about it I figured I would give it a go. Went with the latest stable release, install went fine but upon trying to load the software it tells me that No AMD driver is installed or its not working properly.

Off to device manager and its showing the little yellow exclamation mark and it say windows has stopped this device as its reporting problems, now I cannot get it working for the life of me

I've tried uninstalling and reinstalling driver, uninstalling software, used Radeons DDU it remove all traces of AMD software, tried older versions of the software, everytime it fails

Any ideas as technically it won't switch to the 8870M without the software and I am stuck trying to run any game with the onboard intel chipset!
 

psikey

Distinguished Member
Roll back driver or go back to a recent System Restore point.
 

JimmyMac

Distinguished Member
Ddu cleared out the old drivers and would you believe no restore points on system restore! Turning that back on now

about to attempt reinstalling the old catalyst software that I’ve now managed to get
 

JimmyMac

Distinguished Member
And that’s now failed, even the original software doesn’t seem to work as the driver always fails to work properly!

even though about reinstalling windows, came with windows 7 preinstalled and have the key on the laptop base, however Microsoft won’t let me download as it’s a preinstall version! ***!
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom