Question Unable to play certain channels on FuboTV because "streaming device isn't compatible" (HDCP 2.2)?


Hello everyone! I'm desperate for some help/advice here, because a lot of this video/audio stuff is a bit beyond my usual experience. Here's the situation:

I recently signed up for FuboTV, and I've noticed that some shows (or perhaps the entire station) gives me the following error when I try to watch it:

Sorry, your streaming device isn't compatible to play this video​

Looking up this error on the Fubo website gives me this information:

This error is displayed when the content you’re attempting to watch is protected by digital rights management (DRM) or High-bandwidth Digital Copy Protection (HDCP) and your device is not compatible with the technology used to protect the content.

You may be able to watch the content using your fuboTV login on the channel’s website or app.

I tried watching the same content on the app on my tablet, and it does work there, so I'm thinking the problem must have to do with my TV setup. I have a Panasonic Viera P42G10 plasma TV (from around 2009), so I'm wondering if maybe it's the TV itself that doesn't support something. I have an HDMI cable connected from the TV to a FireTV (first generation). That's the entirety of my A/V connections!

These are the suggestions from the Fubo website:

If you are receiving this error message on your TV, try these steps:
  • The connection between your TV/display and streaming TV devicemay need to be reset
    • Unplug your HDMI cable at both ends, then reconnect it
  • Your HDMI cable may not be compatible with the HDCP 2.2 standard
    • If you have an older HDMI cable or an inexpensive HDMI cable this may be the case.
    • Try replacing your cable
  • Your TV/display is not compatible with HDCP 2.2
    • Try connecting to a different TV/display
If none of these steps allow you to stream the content, unfortunately, the only solution to stream this content on the fuboTV app is to use a different device.

So my questions are:

1. Could it be the HDMI cable itself, as suggested above? I've read that there's really no such thing as a "2.2 HDMI cable," so I wonder if that's even likely. The cable is probably almost as old as the TV, so if there are updated versions of cables, I may not have one.

2. Is it just the TV itself? Back in 2009 I'm assuming HDCP 2.2 wasn't a thing, and if this is required to watch these stations now, then maybe I'm just out of luck. I looked through my TV manual (yes, I still have it!) but I didn't see any specification for the HDMI version. I'm guessing it's at least 2.0, but who knows, could be 1.4 or something!

3. Could it have anything to do with my FireTV instead?

Like I said, I'm not all that great with A/V stuff, so any kind of general explanation of what's going on here would be appreciated as well. I was really hoping I had found a good streaming TV service, but now it seems I may have to settle for not being able to watch some of its included content because it's being streamed(?) with DRM? Or something to do with content protection? I really am not sure, but it's disappointing if that's the case.

Thank you for any help you can provide. Please let me know if you need any further information regarding my setup.


Fred Smith

Well-known Member
FuboTV is not available (legally) over this side of the pond. This is a UK / European website, though all are welcome.

2. TV of that age will be HDMI 1.3 and or 1.4 and not 2.0.

I have a similar age Panasonic plasma, the two HDMI sockets are differnet specs, HDMI 1 is 1.3 and HDMI 2 1.4.


The HDMI interface remembers devices it 'doesn't like' - so whenever you are trying a different configuration / lead whatever, unpower the TV ( Total disconnection) for a good few minutes first so that it will forget and reset the interface.


Oh sorry, didn't realize this was a UK site! I have a feeling that this might not actually be a Fubo issue though. From what I've been reading, it seems like maybe the problem is my TV. It doesn't seem to support HDCP 2.2, although I'm still not clear what this is exactly.

I'm kind of getting HDMI and HDCP mixed up, and if the cable is the issue (I've read there's no such thing has HDMI cables specifically made for HDCP 2.2, etc. and that all cables are the same), or whatever. Seems like a lot of different pieces that I can't quite put together.

As for unplugging the TV power, what exactly will it be forgetting? I haven't plugged in anything new to the TV, just the same FireTV it's always known. The only new thing is the Fubo service.

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom