Quantcast

Unable to get Mobile data plan with Apple Watch

r.vernon1

Active Member
Hi,

I have an iPhone MS Max on o2 with the latest version. I just bought a new series 5 cellular and tried adding the data plan from the Apple Watch app on the phone and I get an error saying Connection failed, the connection to the server has failed, please try later. Anyone else had this and know how to fix. o2 have been useless so far just keep copying and pasting the same info that I have already done. They aren't reading the information I have already given them.

Thanks

Rob
 

Attachments

blu disc

Active Member
Did you buy the Apple Watch from O2. I have the same iPhone and Apple Watch and I bought it from O2 and set up the data plan with them. When I connected the watch to the phone it connected straight away and it said would you like to connect data plan on the watch and when I said yes it connected. Might be an idea to go into an O2 store as they will have a tech person in store who have helped me a few times.
 

D4nM1les

Active Member
I’ve had the same error message since Xmas day woth a series 3. It has sorted itself this evening at last. I spoke to o2 on the phone and they said there was a problem at their end which was being worked on.
 
Top Bottom