TV - Android 55OLED854/12 | Philips - deleting files from external USB drive


Novice Member

Until recently (probably last software update on TV - Android 55OLED854/12 | Philips) I could easily delete files from external USB drive with NTFS file format using file managers like FX File Explorer.

Currently, despite I have given permission to write access; delete/modify files etc., no matter what file manager I would use, an error pops up and I cannot delete files. There are no narratives just internal error message.

Any help is much appreciated. Thanks!


Distinguished Member
The only other suggestion I can make is try a factory reset in the hopes that clears the permissions error.

It's possible Philips changed something for security reasons but there is nothing in the firmware changelog.


Novice Member
Tried. Not working unfortunately.


Novice Member
same here. no write permissions for external storage. have the same issue on both of my Philips android tvs! so annoying.
58PUS8546 with android 10. tried all the workarounds found on the net, no luck.

The latest video from AVForums

The BEST TV of 2023? LG G3 MLA OLED Evo TV Review - COMPARED to Samsung S95C & QN95C
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom