Turntable

SamyBoy13

Active Member
Hello guys I've snatched a real bargain yesterday. Project rpm 3 with bronze cartridge as well as upgraded acrylic platter and spare blue for just under 200 pounds (tt produced in 2018). Im blown away how good old music sounds. However not sure how to keep records clean? Are sleeves actually worth investing inner and outer ? Also what would be a good way to keep my records clean and how to clean them? Further upgrading to black is it worth it over bronze? Lastly stock interconnects are they okay or should I upgrade to better quality ones??

Thanks in advance guys

My current setup
Yamaha as 3000
Yamaha cds 3000
Dali opticon 6
Project RPM3 bronze cartridge and acrylic platter (new addition to my family)

P.s. never thought that vinyl sounds so good.
 
Last edited:

Jampot90

Active Member
Cleanliness is next to godliness:)

Glad you are liking the sound, and yes, clean records make a world of a difference. If you use the search facility there is loads about how to clean already on the site. Opinions vary widely, but 'all roads lead to Rome' as they say.

Certainly, after cleaning it's a no brainer to use a new inner sleeve. I keep 2 anti-static types, a Tonar or Nagaoka flimsy for records which have card or paper inners with information (lyrics, who / when / where, or photos) and poly lined paper for the rest. I don't favour outer sleeves personally, unless you have pristine album sleeves and want to avoid shelf wear and so on they are expensive and bulky.

I'm not sure which bronze cartridge you refer to, Ortofon 2m perhaps in which case it is already seriously better than the usual fitment. I would be inclined just to enjoy it, at least until the stylus is becoming worn.

Jim
 

oscroft

Well-known Member
OK, clean records...

I keep all mine in poly-lined paper inner sleeves. Every time I play, I use a zerostat anti-static gun and then a carbon brush to remove dust.

For longer-term cleaning (which I'm sure I don't do often enough) I use a SpinClean record washer. I'm almost at the end of cleaning all my records with that, and I'm surprised how much dirt has come from records that looked clean.
 

spike47

Novice Member
Hi

I have a Sony Turntable sound problem, the sound is very low, have to turn the Amp up quite a way to hear anything .
My Tuner sound is playing ok through the Amp !

Anyone got any ideas as to what the problem is ?
Cheers

Spike
 

spike47

Novice Member
Sound now ok , had the plugs in the Aux socket instead of the Phono , just the RV settings to sort out as per below , get that sorted then I will be a happy man ."

"Am having problems with setting the values for "All" the measurements on page 11 of the Service Manual, the voltmeter readings are just fluctuating ie "Motor Gain Adjustment" Setting RV2 and RV3 the meter is reading from OL to 3.26 , 2.56,1.96 it just keeps fluctuating up and down those readings.

For the "Offset Adjustment" RV4 and RV5 it is fluctuating between 1.076,0.966,1.167 etc ".

Spike
 

Attachments

  • IMG-0983.JPG
    IMG-0983.JPG
    293 KB · Views: 27
  • IMG-0984.JPG
    IMG-0984.JPG
    245.2 KB · Views: 26
  • IMG-0985.JPG
    IMG-0985.JPG
    292.8 KB · Views: 27
  • sony_ps-11_service manual page 11.pdf
    118.1 KB · Views: 25

SamyBoy13

Active Member
Hello guys, I enjoy the new turntable, ive cleaned few records using a vinyl cleaning brush and clean spin cleaning solution. Out of interest ive put on a old lense on my phone. Struggled to get a clear picture but is the ortofon bronze stylus worn?? What do you guys think, I can tell the is some gunk on it but not sure how a stylus should look. I dont want to ruin my dads 1st release of metalica black album. It appears in mint condition as almost every record my dads owns till this day. Thanks in advance
20-08-30 09_46_25.png

20-08-30 10_09_46.png

20-08-30 10_11_59.png


20-08-30 10_00_42.png
20-08-30 10_11_59.png
 

MaryWhitehouse

Well-known Member
Stylus looks like it needs a good clean. Also maybe bent to one side? Need a pic from head on. Great bargain btw.
 

MaryWhitehouse

Well-known Member
Sound now ok , had the plugs in the Aux socket instead of the Phono , just the RV settings to sort out as per below , get that sorted then I will be a happy man ."

"Am having problems with setting the values for "All" the measurements on page 11 of the Service Manual, the voltmeter readings are just fluctuating ie "Motor Gain Adjustment" Setting RV2 and RV3 the meter is reading from OL to 3.26 , 2.56,1.96 it just keeps fluctuating up and down those readings.

For the "Offset Adjustment" RV4 and RV5 it is fluctuating between 1.076,0.966,1.167 etc ".

Spike

best start your own thread not jump on someone else’s.
 

The latest video from AVForums

Are the TCL MiniLED TVs better than OLED? TCL Interview with Marek Maciejewski | AVForums Podcast
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom