• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

TrueHD not working from BDROM with ATI 5770

nexxer

Standard Member
Hi,

I just installed a BDROM (an LG) into my HTPC, along with an ATI 5770. I am connecting that via HDMI to an Onkyo 508, and from there via HDMI to the tv.

I've managed to get DTS MA bitstreamed from both mkv files (via ffdshow tryouts in kmplayer and MPC-HC), as well as bluray discs (via WinDVD 10.0.1705.51 and TMT 3.0.1.180).

I cannot get TrueHD using the same software from neither mkvs nor bluray discs that include a TrueHD track (eg Dark Knight). It seems to be passed on as DD 5.1 instead. I've played with the settings in both programs without success. I'd expect that whatever worked for DTSMA would also work for TrueHD so I make sure a DTSMA disc works, then pop in a TrueHD one and it doesn't.

Am I missing something? Please help.

Thanks
 

jameson_uk

Prominent Member
TrueHD is quite different to DTS-HD. DTS-HD is built around a DTS core so if something does not understand DTS-HD it will only pick up the standard DTS part.

TrueHD does not have this built in but what has happened is that the studios have interleaved a DD track (completely separate track) inside the TrueHD track. This achieves the same result as above with non PC setups. In PC setups the issue is that often the player will only see the DD part and ignore the TrueHD part. If you are attempting playback from MKV then you might have to play with different SVN versions of MPC Matroska splitter and FFDShow to get a combination that works. Remember all of this is still very much in beta testing so things can start / stop working each time there is an update

Have you tried playing the disc in a player like TMT / PowerDVD which handles Bluray properly?
 

speighty

Prominent Member
I know this sounds silly but did you select the true hd track on the dark knight blu-ray as it automatically selects standard dd 5.1 and you have to manually select it everytime.

I use a HD 5450 and can bitstream dts hd and true hd fine using tmt.
 

nexxer

Standard Member
Well don't I feel silly now. Turns out it was exactly what speighty said. I had noticed the 3 english audio tracks in TMT's menu, and since they had no informational label I had tried them all, but without success. After reading your replies I figured I'd give it another shot since I had indeed changed a couple settings, and channel 2 is the TrueHD one! Now that I'm thinking about it, I mustn't have tried channel 2 after upgrading to the latest TMT 3.0.1.180.

I still can't play TrueHD on an mkv file I had downloaded to try it out, but I'm not too concerned about that as long as bluray discs play well. At some point I may retry combinations of ffdshow and matroska splitter.

I must say I'm a bit surprised the TrueHD track wasn't auto selected based on the capabilities of the setup, or even be the first track listed. I don't have any other bluray TrueHD discs so I can't tell if that's a usual occurence. In Return of the King, DTSMA was selected automatically.

In any case, thank you both for your answers.
 

jameson_uk

Prominent Member
I must say I'm a bit surprised the TrueHD track wasn't auto selected based on the capabilities of the setup, or even be the first track listed. I don't have any other bluray TrueHD discs so I can't tell if that's a usual occurence. In Return of the King, DTSMA was selected automatically.
AIUI the disc has a default track set when the master it and now it is mentioned above I do recall seeing this before that The Dark Knight has it set to the DD not TrueHD track (this is not one of the discs I was talking about with a combined TrueHD/DD track but it has separate ones.
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom