Trouble with X850D enhanced HDMI output and Yamaha receiver

jalder16

Novice Member
Hi all, I've got a tricky problem I need some help pinning down. I have a Sony XBR-55X850D connected to a Yamaha RX V383 stereo receiver and they aren't playing nice together when it comes to Enhanced HDMI output. The Yamaha RX V383 has 4K 60p, 4:4:4 passthrough and is connected with a high speed 18 gbps HDMI cable, and the receiver has the current firmware. The cable is 35' through the walls and attic, but I don't think the length is my problem. When I set the Sony TV to enhanced HDMI output mode any 4K single coming through the receiver shows up on the TV as a blank no signal screen. 1080p signals will come through (ie a cable box), but not 4K (I'm testing with a 4K blu-ray player and an Xbox). If I set the receiver to upscale to 4K, then everything shows up on the TV as no signal (ie the cable box 1080p signal gets upscaled and no dice).

This has been the situation for me for sometime. I've gotten by for years using standard HDMI and my 4K blu-ray player would display 4K HDR content without needing the enhanced HDMI setting. The rub is I just got an Xbox Series X, which detects your TVs capabilities to display the best resolution. If the Xbox is connected via the receiver and in standard HDMI mode it "sees" the connection capable of 4K output, but not HDR. I can temporarily bypass the receiver and put the TV into enhanced HDMI mode and the Xbox properly detects all the correct HDR functionality (even over my 35' cable, which is why I don't think it's the cable). So my problem boils down to: I need the enhanced HDMI input setting on for the Xbox to correctly display HDR, but because of some weird combination of my TV and Yamaha receiver, when enhanced HDMI is on, all I get is no signal on the TV. The Xbox is why I want to fix it, but the Xbox isn't really the source of the problem. The linkage between the Yamaha receiver and the Sony TV when in enhanced HDMI mode is the problem.

If worse comes to worse I could run a second HDMI cable through the attic and walls so the Xbox would plug into the TV directly, permanently bypassing the receiver. I have an optical cable already in place to return sound for SmartTV apps like Plex and Netflix. I hoping someone here will have some master advice or tips before I go out and buy another 35' cable and muck around in the attic. If swimming in insulation weren't bad enough, I have to tear down all my receiver speaker wiring to get to the wall panel to run the cables.

Thanks for any help!
 

The latest video from AVForums

LG G1 OLED EVO Review (OLED65G1)
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom