Trackpad stopped working!

Discussion in 'Apple Forum' started by 1iam5mith, Aug 30, 2013.

  1. 1iam5mith

    1iam5mith
    Well-known Member

    Joined:
    Jan 23, 2012
    Messages:
    5,768
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Ratings:
    +812
    My trackpad had 11% battery left, so u decided to change the batteries. So I put I. 2 fully charged rechargeables, and now it won't turn on? No green light at all! I have tried all the tricks when looking for a solution online, tried different batteries, tried using a little but of foil in with them incase the spring isn't working, tried pushing the spring with the end of a pencil, and still nothing!

    I spoke to Apple on the phone because I have AppleCare, they said to take it into a store for a replacement, but not appointments available before Tuesday!

    Luckily I have a remote mouse app on my iPhone, so I can go on there if I really need to ( though if I could get away with not, I wouldn't, the app is horrible!)


    Anyway, has anyone else had this issue? Any ideas on things I can try to see if I can get it working?

    I really don't want to be without it lol


    Thanks in advance :)
     

Share This Page

Loading...