Toshiba XS34 display problem

Discussion in 'Blu-ray & DVD Players & Recorders' started by alan8477, Jul 15, 2005.

  1. alan8477

    alan8477
    Active Member

    Joined:
    Dec 17, 2001
    Messages:
    577
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Pershore
    Ratings:
    +5
    Out of the box today, and everything on my Toshiba XS34 is working except for the LED display. I have tried pressing dimmer button on the remote, but it does not bring it to life. I am assuming it is faulty.

    Any suggestions?
     
  2. JayCee

    JayCee
    Well-known Member

    Joined:
    Jan 20, 2004
    Messages:
    20,342
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Lanarkshire
    Ratings:
    +1,954
    Send it back........it is obviously faulty.
     
  3. al4n

    al4n
    Standard Member

    Joined:
    Jul 16, 2005
    Messages:
    15
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    have you got eco.mode turned on it sets the front panel display to turn off in the standby mode.its in set up -management settings.
    hope that helps only had mine a week trying to find out how to turn on programme delivery control at the moment .
    alan
     
  4. alan8477

    alan8477
    Active Member

    Joined:
    Dec 17, 2001
    Messages:
    577
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Pershore
    Ratings:
    +5
    Thanks all. Spoke to the Toshiba Helpline and RGBDirect, it's going back on Monday. In the short time that I have had it, I am impressed with its facilities. Not quite as convenient as the +R/RW system when it comes to use of discs on other players. But at least it does play my +RW discs.

    Looking forward to it coming back. Have to use my old Philips recorder until the Tosh returns.
     

Share This Page

Loading...