Toshiba XP1 - No sign of powering up

bizres

Novice Member
Hello,

I purchased a used Toshiba XP1 projector from a seller on the Facebook Marketplace in Dubai.
The guy is known for selling used projectors of different brands.

When he delivered the item, he powered on the device and it powered on OK.

However, thereafter it does not power up.
I connect the power cable, and no sign of life. No lights, no sound,,, nothing.
I have tried different power cables but no luck, yet the same power cables work well on other devices.

I've asked the guy and he just says it is OK and the fact that he powered it on when he delivered bla bla. So I don't want to bother with him.

My question is, has anyone using the Toshiba XP1 experienced such a problem, and did you manage to solve it?
If yes, then I'd really appreciate some ideas?

(just a silly thought, any fuse anywhere that would need replacement?)
 

Spigot

Active Member
There will be a fuse on the power supply board but they don't look like plug fuses, more like a copper coloured cylinder. That youtube channel linked above (fixitfrank) has videos where he diagnoses power supply issues using a multimeter.

When my projector (Optoma) died (with a loud bang) I got a power supply board from Aliexpress, couldn't find one on ebay. There's an old listing for a power supply for a Toshiba TDP-XP1 on ebay, don't know if listing is just expired or item sold, you could contact them: TOSHIBA TDP-XP1 POWER SUPPLY BOARD

Don't know if this is compatible, again best to ask seller. Free returns if it's the correct power supply but still doesn't resurrect your projector: Power supply CT-X300J/F1
(you can see the fuse on the bottom left of the board above the screw hole, that can be checked for continuity.)
 

bizres

Novice Member
Thanks so much for the detailed information.
At least I now know there's hope to get the device up and running.
 

bizres

Novice Member
Just came across this:
Toshiba TDP XP1 Power Up Problems

Looks like a similar problem to mine.
Interesting to note what someone has written down the discussion,
It turns out that the little plastic striker moulded to the lamp replacement cover was deformed/warped (possibly by heat?) and eventually it must have got to the point of not switching the micro-switch into the closed safe position. (I assume it there so that you can not power up the unit whilst the lamp cover is off, which would make sense) With the power effectively on and being very careful, I manually depressed the micro switch (with something plastic) the projector jumped into life!
Wonder if mine is facing a problem like this🤔
 

bizres

Novice Member
Something amazing happened.
I connected the projector to the power and as usual there was no sign of life. So I really pressed the power cable into the projector and moved it about (pressing really hard) and the standby/ON indicator turned on Orange for about 1sec and went off again.

Thereafter I re-tried the same process several times but no luck.

Any idea what that could indicate?
 

Spigot

Active Member
Perhaps one of the wires that connects the pins on the socket to the power supply board has a loose connection or bad solder joint. It would mean dismantling to inspect.
Power-supply-crop.jpg
 

Spigot

Active Member
I only recently disassembled my projector (Optoma) using a service manual as guidance. Took me hours and I was sweating bullets disconnecting all the cables! If you decide to do it then it's a good idea to take pictures of everything before removing screws/cables.

It's basically 1) remove lamp, 2)remove screws from base, 3)remove top of case (careful of any ribbon cables to control pad), 4)remove screws for video inputs at back of case, 5)remove shielding, 6)unplug cables to main board including power supply which connects underneath, 7)lift out main board (which has a push on wafer connection at the front to the dmd chip). Should then see power supply. I just looked for any bulging/distorted capacitors or scorch marks and fortunately saw a blown chip.

Even though this is a different projector it gives you an idea of what to expect disassembly wise:
DLP Projector Power Supply Replacement
I notice the service manual mentions the interrupt switch that is connected to the lamp cover, like you said above it's something else that might be causing your problem. Hopefully it's something somewhere that just needs re-seating. Good luck if you have a go at it.

(Just saw this video, guy has a Toshiba TDP-S8 that intermittently powered on and it was a blown capacitor on the power supply board: Repairing Toshiba TDP-S8 )
 

bizres

Novice Member
Oh, it's like performing a C-Section
Building the courage and getting hold of a soldiering device.

Wish me luck
 

The latest video from AVForums

Podcast: Sky Glass, Epson Laser Projectors plus Home Cinema Subwoofers and More…
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom