Toshiba TV drops WiFi connection

colmde

Novice Member
Just wondering if anyone else has come across this and what can be done to help.

I have a Toshiba 50UA2063DB Smart TV. For some reason it seems to drop its WiFi connection every now and again. I could be watching anything and a message will suddenly appear on the screen saying that the WiFi has been disconnected.

Other times it just seems to disconnect without any message. If I go and check on the Home screen, I can see the WiFi symbol with a circle alongside it. If I go into the WiFi options, I can see my network but there is a message below that says "Authentication Problem". At this point, I can't seem to reconnect - I just keep getting this "Authentication Problem".

However, the authentication should be fine! It works fine until this spontaneously happens, and nothing changes about the TV or the router's settings. If I turn off the TV and turn it on again (full power down - i.e. hold the remote control power button for a couple of seconds), then it works fine again (but for how long?)

This is all very annoying, as I don't want to be continually turning off and on the TV intermitently. The telly isn't far from the router (like within 1m) and this doesn't happen to any other device using WiFi in the house.

What is happening here and what can be done about it? I haven't yet tried an Ethernet cable and I'd prefer to continue to use WiFi because the design of the unit they're both in would make the cable awkward.
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom