Toshiba SD900E Noisy Transport

Discussion in 'Blu-ray & DVD Players & Recorders' started by chicken balti, Sep 17, 2001.

  1. chicken balti

    chicken balti
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi guys, wonder if anyone else has spent an arm and a leg on an SD900E and been impressed with the AV performance but brought crashing back down to earth with the transport noise?

    Put a disc in and a succession of whistles and whirrings accompany disc access and stay there until you select play. Even then they continue for a while until the noise eventually disappears after 10 or 15 minutes. You can get rid of the noise a little quicker by hopping through the chapters but please, for a £1300 deck this is a taking the ****.

    Has anyone else out there had the same problem, or have I got a genuine fault? Deck came from Techtronics and works flawlessly but the noise has got right on my tits. <img src="frown.gif" border="0">
     
  2. Silver

    Silver
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    My sd900e barely makes any noise at all, I would take it back and get them to swap it for another.
     
  3. AlfaKhan

    AlfaKhan
    Active Member

    Joined:
    Aug 7, 2001
    Messages:
    250
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Cascais, Portugal
    Ratings:
    +6
    Hi Brendan,

    I've just received mine from Germany today.

    No whistles or whirrings here. Just smooth silk operation.

    ...then, again, Germans would not allow a noisy deck into (and out of) their orderly country, would they? <img src="biggrin.gif" border="0">

    HB
     
  4. I am maximus

    I am maximus
    Standard Member

    Joined:
    Nov 14, 2000
    Messages:
    73
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Surrey,UK
    Ratings:
    +2
    Hi I also have the same player from Techtronics it also makes a tremendous noise when playing usually for the first ten minutes or so then disappears until 10 mins before the end.I think that we have same problem after contacting Techtronics they suggested that the carrier had damaged it (nonsense).They then said if I sent it back too them I will get charged if its found that its within tolerances hence frightening me into not sending it back .Let me know how you get on!!!!!
     
  5. Damian1978

    Damian1978
    Well-known Member

    Joined:
    Jul 15, 2000
    Messages:
    4,498
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    107
    Location:
    Fleetwood, Lancashire
    Ratings:
    +266
    Hi,

    The whirring noise does not sound good. I'm awaiting a replacement (and have been some time) because of a dodgy display but the two I've seen and used were absolutely silent apart from once with a Jamiroquai CD. Once I ejected it and replaced it in the drawer it was silent.

    That happened just once on the multiregion shop model.

    Perhaps they have messed with the drives firmware?

    You can tell Techtronics its not to spec. I'm sure Toshiba would back this up to.

    Good luck <img src="wink.gif" border="0">
     
  6. chicken balti

    chicken balti
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks for all the replies. Seems that Germany is the best place to buy a Japanese DVD player if youre living in the UK!!! Anyone experiencing the same problem as I have had might be interested in the response I got from Toshiba's technical support centre. The reply was straight and to the point, the 'appliance', as they call it, should not exhibit this type of noise and has a fault. If I return it to the supplier I can get the appliance exchanged. Looking at some of the replies to my original query I think I may have a hard time getting any joy from Techtronics. I'll let you know how I get on.
     
  7. axis45

    axis45
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    My sympathies mate,your situation is a f****ng disgrace,paying all that money to Techtronics for such a botched job.They seem to be complete "cowboys" who don't give a **** about their customers.<br />I got a modified jvc xv 723 from them,it had a dent in the chassis and the macrovision was still working on certain discs,plus they didn't send the free dvds included in the offer.Been waiting over 3 weeks for a replacement now,they promised it this week but it didn't show again,and it is virtually impossible to get thru to customer services on the phone,plus they NEVER reply to any answerphone messages u leave with them.<br />Ask for your money back mate-no question-the law is on your side[Sale of Goods Act-speak to Trading Standards]-tosh have confirmed it is clearly faulty-don't accept the pile of crap they have sent you.Sue them in fact.Good luck.
     

Share This Page

Loading...