Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

Toshiba SD330e + spiderman problem

Discussion in 'Blu-ray & DVD Players & Recorders' started by Shimmyhill, Dec 21, 2003.

  1. Shimmyhill

    Shimmyhill
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I just picked up a Toshiba sd330e and so far i have been pleased with it.

    However while i was watching Spiderman (R1) it frooze and would not continue playing past the scene, you could go back ok but could not forward past the freeze.

    I skipped a couple of chapters and it happened again.

    Is this likely to be a disc error, a compatability problem etc.

    Every other disc i have played, both r1 + r2, have played flawlessly.
     
  2. bonzobanana

    bonzobanana
    Well-known Member

    Joined:
    Aug 21, 2001
    Messages:
    3,449
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Yeovil
    Ratings:
    +220
    Have you tried the same dvd on another player? Sadly if theres one thing that isn't great on the toshiba its the dvd loader, mine started playing up after less than a couple of months and I sent mine back to Amazon and got a refund. Others have reported frame skipping problems. However enough of my negative vibes. Things will be a lot clearer once you know if the dvd is geniunely poor/faulty or its just your player.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice