1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Toshiba SD330E - dead?

Discussion in 'Blu-ray & DVD Players & Recorders' started by mister_d, Sep 22, 2003.

  1. mister_d

    mister_d
    Standard Member

    Joined:
    May 23, 2002
    Messages:
    228
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +1
    I bought a region-free Toshiba SD330E from Richer the Saturday before last, and used it a couple of times before taking it downstairs last night, with no problems whatsoever - since bringing it back up, though, I've been unable to get anything out of it. When I turn it on, whether by pressing the power button or an appropriate button on the front/handset, the power light goes green for approximately 5 seconds (during which time it won't respond to any button presses, and nothing appears on the LCD), then it beeps quietly and turns itself off again.

    It's quite possible I'm doing something completely idiotic here, but at the moment I can't think what. I've tried a couple of cables and power sockets with identical results. Has anyone come across a similar problem with this model, and am I going to have to get it replaced?

    Before anyone asks, there definitely aren't any DVDs (or, to my knowledge, anything else :)) lodged in there.
     
  2. AOD

    AOD
    Active Member

    Joined:
    Feb 7, 2001
    Messages:
    707
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    London
    Ratings:
    +4
    It does indeed sound like a duff unit.

    Your best bet is to go straight back to Richer Sounds and get a replacement. Call them first to check that they have another machine in stock.

    If they can't replace it immediately, I would get a refund and go get it elsewhere.

    Of course you could always give their customer service dept a ring as well to see what they say.

    Good luck.
     

Share This Page

Loading...