Toshiba Satellite C50-A-19T laptop

cutter48

Novice Member
Bear with, this could be a bit long winded.
My Toshiba laptop battery died, but obviously still works on the power lead. So, I bought a new battery that although not from Toshiba should be compatible. I fitted and charged it up fully, but now when I start my laptop all I get is a black screen, the power lights are all on though and I can't hear the fans going.
I take off the battery and revert to just the power lead and all's well, so , while all is well I refit the battery, lo and behold I can use the laptop fine even with the power lead out.
So I shut down, go to start up and I am back to the black screen again!
Doing my nut in. I have tried online solutions but nowt seems to work
Question, do I have to do anything in settings when fitting a new battery?

Also, I did a full reset on this laptop because there was so much crap on it over the years and it was running like a pig. (Had the battery issue prior to this) and everything almost was 100% better, its faster for certain.
But the internal speakers do not work since resetting. I read that I should uninstall / reinstall the driver for sounds, so I uninstalled it but cannot find where to reinstall! This isn't as big an issue as the battery as I have a bluetooth speaker thats fine, but would like to resolve it.

All this because I bought a new Chromebook laptop but cannot get my head around it!!

Next stop is the skip I think
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom