Toshiba LCD regza 42 WLG66, Overscan problem, VGA connection problem, is it 1080p-i


Novice Member
I have a few problems with my big Toshiba LCD regza 42 WLG66, its a Euro model:

1. In all of the specs it says that it is a FULL HD, but when I connect it on my pc, via the various connections, the maximum it gives me is just a 1080i.,is this lcd truly FULL HD (1080p) or is it just a HD ready (1080i), I dont count re-sampling as a 1080p feature, can it inject the 1080P source or not? It seems that guys at a Toshiba store lied me when they told me that this model is a true 1080P. If just the panel is 1080P what's the use.

2. Every connection that I used (VGA, Y/Pb/Pr component, DVi-->HDMI) I couldn't get a 1:1 picture (pixel on pixel).
The picture always ends up in a huge overscan-out and it was in blurry non native mode, and since NVIDIA decided that the overscan compensation can only be allowed (or used) on a composite Y/Pb/Pr connection, the question is how could I do the underscan compensation on VGA or on Dvi(dvi to hdmi) connection from the NVIDIA driver, ?

I will explain the situation litter more:
How to fix OVERSCANNED output if you use VGA or DVI-->HDMI connection on a Big LCD Displays,
strangely NVIDIA decided to enable overscan and underscan compensation correction trough their overscan tool, but this tool could be used only when you connect your Big LCD display trough the composite Y/Pb/Pr connection.
If you use this type of connection you will see new option in the nview settings, when you try the right mouse button on the display you connected on a composite Y/Pb/Pr connection.
Why the NVIDIA decided to give such great tool just for the composite Y/Pb/Pr connection, and why they leave their customers suffer overscanned picture when you use a VGA or DVI/HDMI output.
If I succeed some how to compensate overscan trough NVIDIA tool, will I be able to pop-into the 1:1 pixel proportion.
I cant stand the blurry image in the non native pixel mode.
Is there some inf tweak which could enable overscan tool on all connections including the VGA and DVI/HDMI, and some way to enable 1:1 in a wide resolutions.

I heard on some forums that some new driver versions such as 96.89 and above could fix the described problems, but my NVIDIA cards doesn't support newer versions, I have few card in few laptops and desktops such as a 420go, 440go, 7300GS and 7600GT. They are not supported.

Some inf tweak would be wonderful.

3. Why does this model has a problem with a VGA connection?, while on this connection my Nvidia 7300gs does not recognize it as a wide VGA model, thus treats him as an analog device. Whilst on the other connections (DVI-->HDMI or composite Y/Pb/Pr) it sees it as a Toshiba (on dvi to hdmi connection) or as HDTV (on a composite Y/Pb/Pr connection).
Is there a way that this model could be recognized on VGA connection as a Toshiba device.
I tried 5 Sony LCD models and 3 LCD Samsung models and few LG LCD models, and I had no problems on VGA connection, Nvidia card instantly recognized them as it should and it instantly enabled wide resolutions in a perfect 1:1 pixel proportion.

4. Will I be able to fix overscan and 1:1 pixel proportion trough the service menu settings?

motile rod 2

Novice Member
1) It's not 1080p, 1080i only.

2) Errrr, dunno.:rolleyes:

3) Because it can only accept 1024x768 over vga. All the WL66's are notoriously crap for connecting to PC's with. Sony's and LG's work much better with PC as they can accept up to 1360x768 over vga.

4) Probably not.

So yeah, these tv's are terrible to use with PC's, just grin and bear it.


Novice Member
Try a programe called 'powerstrip' - it may help you get the correct pixel ratio.

I tried with the Power Strip, but I didn't succeed, as I remeber that the only resolution similar to a 1:1 pixel proportion was the resolution I got over the VGA with a 1280x1024 with the left and right black borders.
Every other wide resolution gave me non-native pixel proportion and big overscan.

Could you tell me how did you thought to do it with the Power Strip exactly?


Novice Member
I succeed with the 1:1 pixel proportion on the DVI-->HDMI connection.
Its impossible on this device to enable so called native resolution of 1360x760.

If you put the custom resolution of 1360x768 you can see a good pixel on pixel resolution (sharp picture but with the huge overscan), the next step is to enable in the latest NVIDIA drivers, the option called overscan compensation,
(which are fixed in this latest drivers, for the overscan compensation on other connections beside the component out),
but firstly, you must enable the option to treat the display as a HDTV device),
you will see that the overscan compensation will pop-in as a new option,
than when you compensate the overscan to the right size, you will get the end resolution of the 1288 x724, this is the only possible way for the 1:1 pixel res. in any full resolution over this connection.
But with the latest drivers you can get the 1:1 pixels with an enabling the 1080i resolution, with this resolution, there is no need for any overscan compensation, (but of course you must enable the option to treat device as HDTV),
than you will see the HDTV resolutions, and the predefined timing settings for the h/V freq. and scan rate for the 1:1 pixel proportion. Of course the 1080i is the only 1:1 resolution of all HDTV resolutions.

I hope that I solved problems for anyone who had or still have this HDTV device.

The latest video from AVForums

Podcast: Sky Glass, Epson Laser Projectors plus Home Cinema Subwoofers and More…
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom