Toshiba HD-EP30 firmware 1.3 problems

nik_h

Standard Member
Hi all have updated firmware from version 1.0 to 1.3 and i am still having playback issues it keeps stopping/freezing then gives me a disc read error,i then have to eject the disc and start over again FF to the chapter where it stopped then it seems to play fine but only for about 20 mins at a time then i have the same problem?

Disc is 300

anyone else having playback problems with FW 1.3 ?
 
R

Richard QC

Guest
Yes, lots of people are! Quotes keep appearing in lots of different threads about freezing, lock ups etc, but nobody has an answer. Some say firmware, some say poor quality lasers, some say faulty discs.....

I have an EP30 on v1.3 and have played 4 films, 2 have had failures.
Dreamgirls crashed after about 1h:15, I had to switch the TV to a different input then back again to resume playback. My TV actually went blank and the error light started flashing on the TV (I thought the TV had died at first).
Harry Potter (the latest one - US disc), started pixelating and freezing after 1h:09, again had to switch inputs and then back to HD DVD input to make it work, rewound it and tried again and it worked fine. This time the display did not go blank but gradually the pixellation and blocking got worse and quickly became unwatchable - the sound also kept dropping and this is connect through the optical output.

Transformers player ok as did 300 all the way through.

So my thoughts always around 1h10 to 1h15 into a disc, need to change inputs to what I think is re-establishing a HDMI link and all works ok.

I have a 55" Sony SXRD connected via a HDMI switchbox. Sky HD and Samsung SD HDMI DVD player work fine through the switchbox into the TV so I suspect a problem with the HDMI output/software in the HD DVD, could be disc related but not sure!

Any feedback would be appreciated. Anybody contacted Toshiba over this?
 

eatstatic

Active Member
nik_h,

I have (had) an HD-EP35 v1.3 which is being collected tomorrow.

I spkoe to Toshiba regarding the freezing issues on certain discs 300 being one of them (although it was the 300 combo disc). Persitant problems on chapter 23 at time 121.42 onwards. Same when ejecting trying again etc.

This disc played fine on my HD DVD 360 add-on. All other discs that the player failed on were new and played fine when checking on add-on.

Having described the problems I was having I got an intant answer stating that I had a faulty player. I got the impression that this was a common complaint to Toshiba.

Getting replacement soon (I hope....), will try the EP35 once more).

Would contact Tosh to see what they have to say about you EP30 if it was me.

Good Luck,

eatstatic
 

mike_tv

Standard Member
I got an EP30 from Tesco on Sat.

After upgrading the firmware I have played :

300
Harry Potter ( second most recent one - Goblet of Fire I think )
Bourne Ultimatum
Full Metal Jacket
Batman Begins

And a number of DVDs - all with no problems during playback.

I had a slight problem with Bourne in that it said 'Loading' for ages at the start, after waiting a while I pressed the Enter / OK button on the remote and it started playing!

Sounds like the issues people are having are down to faulty players.
 

nik_h

Standard Member
Have spoken to Toshiba today and have been told to return the player for an exchange incase it's faulty,i was also told that they a working on a new firmware version 1.4 due out shortly as they are aware that there are still a few problems with fw version 1.3.
 

simon69

Active Member
Does this problem include a slight freeze on layer change?
 

nik_h

Standard Member
it's not a slight freeze it's a permanent freeze it stops and the only way to get it going again is to eject the disc,if you press stop and play it says ''unable to play format'' thats why i have to eject it,as far as im aware you will always get a slight pause between layer changes due the the laser unit refocusing/moving
 

simon69

Active Member
Is there no buffer in the player? I had a £50 LG player and it was not possible to see the layer changes
 

clarkkent

Standard Member
Updated mine today via the web but upon completion after 39/39 mine froze after step 4/4 if that makes sense to anyone!!!:eek:

Player wouldnt do anything at all apart from turn on and off so i took it back to tesco and got another one where i accidently forgot to put the 2 free dvds in so i have to lots now!!!:smashin:

Dont think il bother with the update with this one just yet :(
 

Pulse1

Well-known Member
My EP-30 got picked up today as toshiba says it's probably faulty as i have done the update and still getting loading,break-up and freezing problems.The best way for this to get sorted out is if everyone who has problems with their player is to get in contact with toshiba and let them know :thumbsup:


Brian
 

biccus1

Active Member
My EP-30 got picked up today as toshiba says it's probably faulty as i have done the update and still getting loading,break-up and freezing problems.The best way for this to get sorted out is if everyone who has problems with their player is to get in contact with toshiba and let them know :thumbsup:


Brian

Are they replacing or repairing?

shane
 

gkpm

Novice Member
Not sure how to explain it but my EP35, which I upgraded to 1.3 straight out of the box, crashed quite frequently, had disk errors and sometimes drove my Onkyo 605 where it's plugged quite mad.

2 weeks after its fine, haven't had a crash for ages! Not even a delay in switching layers, and this is with rentals (had Lovefilm and Amazon) or bought. True sometimes after skipping chapters or choosing stuff on the menus the Onkyo gets a bit confused as to what audio type is coming in and I need to cycle the input (e.g. change to TV and back to DVD) but thay might be the bitstream stuff which is new, otherwise its just perfect.

Very odd, probably should take an extended warranty on it, but seeing how prices are coming down it might not be worth it ;)
 

simon69

Active Member
You probably know this already....

I have just this minute spoken to the toshiba customer support department. Firmware 1.3 was supossed to fix the freezing problem on layer change on HD. They said it should not be noticable at all with SD disc's. The have given be a reference number to return my player.

I asked if this was a generic problem, she siad no but they have had a number of units that are faulty. I dont know whether to try another EP30 or go for a different model, or just forget about HD DVD, which is sad as when they work they look and sound good...
 

eternaldark

Novice Member
Updated mine today via the web but upon completion after 39/39 mine froze after step 4/4 if that makes sense to anyone!!!:eek:

Player wouldnt do anything at all apart from turn on and off so i took it back to tesco and got another one where i accidently forgot to put the 2 free dvds in so i have to lots now!!!:smashin:

Dont think il bother with the update with this one just yet :(
once it gets to step 4/4 it will freeze for a while (30mins or so ) its perfectly normal, let it do its thing while watching telly or something.
 

nik_h

Standard Member
i have now returned my player to Hughes Electrical in Norwich where i was given a full refund,as it turns out they have had a couple returned and don't currently have any in stock,the manager seems to think that there order had not been dispatched due to the firmware problems Toshiba were/are having and since the end looks near for HD DVD they may not get more stock so i decieded to take the refund and run and for now i'll stick with blu-ray.....seems a shame really as i thought the picture quality was excellent and as HD DVD discs are cheaper to produce than blu-ray i honestly thought that it would be the winner, but im not willing to take the risk and get another hd dvd with the warner saga an all then find that in 6 months it's worthless.:suicide:
 

simon69

Active Member
It would help toshiba and HD DVD if they released players that worked, its alright having the format finished but if they dont work............. Play.com have had loads of players returned I suspect other retailer are the same. If HD DVD wants to continue Toshiba should be saying "hey we are here with a finished format and have all these great players that work" and do some adertising!

I was fairly happy with my player, but now that it is being returned Im not quite sure what to do.......
 

Pulse1

Well-known Member
Well toshiba have my player atm so i'm going to wait and see what happens,I'm not giving up on hd dvd yet as to me it's still worth investing in :) I also have blu ray and currently have more hd dvds than blu ray titles though not by much but it depends on the titles released and both formats have exclusive titles to their own so that's the attraction for me.As long as this is the case i will be sticking with both because they are both as good as eachother quality wise.....Afterall you by the discs for the movie and not the features :lesson:



Brian
 

mxs

Novice Member
I am one of the lucky people who have had no problems at all with my EP30 :D Brilliant audio and no problems with playing both SD & HD discs. :D:D
 

Indiana Jones

Moderator
I am one of the lucky people who have had no problems at all with my EP30 :D Brilliant audio and no problems with playing both SD & HD discs. :D:D
Same here, have watched several SD and HD-DVD's and not had a single problem.
 

simon69

Active Member
Why is there so much difference across the model, mine kept freezing and crashed, some poeples just crashed!
 

serpico77

Distinguished Member
I have a new HD-EP30 player and while I was watching red dragon last night I needed to pause the film. After a few minutes a got this error: 408BC504.
As soon as I pressed play it started up again but from the beginning.

My firmware is 1.1/1.1. What should I do? Anyone else had this problem?
 

Pulse1

Well-known Member
I have a new HD-EP30 player and while I was watching red dragon last night I needed to pause the film. After a few minutes a got this error: 408BC504.
As soon as I pressed play it started up again but from the beginning.

My firmware is 1.1/1.1. What should I do? Anyone else had this problem?
Give toshiba a call and they will send you out the 1.3 version update disc :smashin: Then if you get anymore problems like freezing/Break-up or crashing issues it's faulty.


Brian
 

Pulse1

Well-known Member
Could I download the update?
Yes,but your better to burn it onto a disc first and use the disc rather than connecting your player to the internet as some people were having problems that way :thumbsdow ie. Their players were getting bricked etc :mad:



Brian
 

The latest video from AVForums

Podcast: Marantz SR7015 & NAD T 778 AVR + Mission LX2 MKII Speaker Reviews, AV & Film News and More

Latest News

Campfire Audio updates Vega and Dorado earphones
  • By Andy Bassett
  • Published
Oppo launches S1 and R1 4K smart TVs
  • By Andy Bassett
  • Published
Lithe Audio AirPlay 2 ceiling speakers world's first
  • By Andy Bassett
  • Published
Humax launches AURA 4K Freeview Play Recorder
  • By Andy Bassett
  • Published
Fyne Audio adds new standmounts to F1 speaker range
  • By Andy Bassett
  • Published
Top Bottom