Toshiba External 1TB format to EXT3

strog25

Standard Member
Hi, I hope someone can help. I have just bought a 1TB Toshiba external HDD to backup the likes of Life (in HD) from the Humax. I am running out of disk space. I have tried using a SLAX Live CD (Linux) to format it to EXT3 (for HD, get over the 4GB limit), but everything I have tried I cannot seem to get it to work. Can anyone help. I have tried Graham's excellent instruction but they do not seem to work. Thanks in advance. Rob
 

TonyA

Well-known Member
When booted into SLAX, is the external disk being seen by SLAX?

If you boot up with the external disk not plugged in, and after booting, then plug it in, do you get any notification that the drive has been "mounted", or do you get any prompt concerning the drive?

Once booted without the drive attached, go into the "Konsole" application (the icon looks like a computer screen and is in the bottom menu on the screen). You can access the Linux bash shell command line from here. Type in the following (where <RETURN> = Press the RETURN key):

df <RETURN>
fdisk -l <RETURN>

Both of the above commands will output the current disk partitions mounted to the system, and the disk partition layouts on the physical hard drives.

Plug the 1TB removable drive into the system....

Repeat the above commands... Are there any changes to the previous time you did the commands?
 
Last edited:

strog25

Standard Member
Hi thanks for the reply, it gets mounted and I can format I think. Just when I plug it into the Humax it just doesnt recgnise it. says it must be either in FAT32 or EXT3 format. I tried to use Garahams instructions but I ran into problems with the later part. Below are the instructions I followed. Can you tell me if it should be any different using SLAX and 1TB HDD.

"Carefully type and enter the following

mkfs.ext3 /dev/sda1

Next step is optional it let's you give the drive a name the example calls it FoxsatBU

e2lable /dev/sda1 FoxsatBU

Now to set the partition type

fdisk /dev/sda

type t and enter

enter 83 at the prompt

type wq and enter

close the Konsole window

Click on the world icon and then media manager

Right click on the USB icon and choose safely remove

Remove the USB drive. Your foxsat should now recognise it and allow large file transfers.

Rob
 

TonyA

Well-known Member
Can you clarify as to what problems you "ran into" please?

Have you tried re-formatting again?

The instructions that Graham provided show the example of /dev/sda1 - this may not necessarily be the exact device name of your removable disk.

Try the instructions as supplied previously above, and if you do see a difference from the output of the "df" and "fdisk -l" commands, the resultant device appearing as /dev/sdxx that is not on the output of the first set of commands, will be the device name for your drive, and this is what you should use for the commands in Graham's instructions.

So if the 1TB disk device appears as: /dev/sdb1 - then you will use "/dev/sdb1" and "/dev/sdb" in the commands.
 

strog25

Standard Member
Hi

I think I know where I have been going wrong, the device name is /dev/sdc1. I used dev/sdc1 in all the commands and not just sdc in some lines, I will give it a try using these and let you know. Thanks for your fantastic support.
 

TonyA

Well-known Member
This is the normal stumbling block for most of us, as the device names can be different from one computer to the next, due to various factors (such as inbuilt/external USB cameras, disks etc...) that might be attached to the computer.

Sounds like you're onto it now. Good luck, hope it all works for you! :smashin:
 

strog25

Standard Member
Whhoooohooo!!:clap:
It worked a treat and I am now busy copying over the full series of Life in HD, that should free up 50% of the Hard Drive ha ha!!

It was the "sdc" and not "sdc1" orignally I had thought it must have been a typo and just put "sdc1" as the previous instruction.

Thanks again Tony and Graham, your assistance is invaluable to me and many others. Cheers.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom