Toshiba EP30 Region Free Firmware - Part 2

Viking61

Well-known Member
There is now a way to make your HD-EP30 region free. :r0:

First of all I want to say that I don't take any credit in making the regionfree firmware. I only modified it to make it run on our players. It is a quite 'dirty method', so maybe it's not for all to do this. The procedure has to be followed very carefully, or you risk rendering your player useless.

The update procedure:
1. Insert the CD with firmware called EP30-dirty1
2. Answer Yes to update
3. The display will show VER UP for awhile, then count until STEP 2/4 before it stops with 10004050 showing on the display. The TV will still show “Updating. Do not turn off.”
4. Let it stay like that for 10 minutes
5. Unplug the power cord, wait 10 seconds and plug it in again
6. Turn the player on with the remote
7. There will not be anything shown on the TV
8. It will show WELCOME in the display for awhile, then it will show VER UP
9. Press Right Arrow (the button to the right of OK) once
10. Press OK once
11. The disc will eject

12. Insert the CD with firmware called EP30-dirty2
13. After awhile it will show VER UP in the display, then you press OK once
14. It will still show VER UP in the display for awhile, then it will count from STEP 1/4 until STEP 4/4
15. STEP 4/4 can take up to 20 minutes. Just wait and let it run its course.
16. The disc will eject and the player will turn itself off
17. Remove the disc and turn the player on with the remote
18. It will show WELCOME for awhile and then a small update will run, only STEP 1/1 and the player will turn itself off again.
19. Turn the player on with the remote and you have a regionfree EP30

You can now update to version 4.0 and still keep the regionfree setting.
If you don't feel up to it, then it's better not to try. Hopefully there will come a better way to do it in the future. Having said that, the procedure have been tested on 4 players and all of those are now region free.


To make your EP30 or A30 (incl. PAL capability) region free:
1) EP30-dirty1
2) EP30-dirty2
3) Update your now region free player with the EP30 version 4.0.

To crossflash your EP30 or A30 (incl. PAL capability) into region free EP35-mode:
1) EP30-dirty1
2) EP35-dirty2
3) Update your now region free player with the EP35 version 4.0.

To make your A35 into PAL capable region free EP35:
1) EP35-dirty1
2) EP35-dirty2
3) Update your now region free player with the EP35 version 4.0.

To revert your EP30 or A30 from EP35-mode to EP30-mode:
1) EP35-dirty1
2) EP30-dirty2
3) Update your reverted player with the EP30 version 4.0.

If you decide to crossflash your EP30 or A30 into EP35-mode, you can see how bitstreaming will work in this post.

If you have an A30 or A35 and plan to make it into a regionfree EP30 or EP35, please ensure that your TV or projector can handle PAL before starting the process. Even though the EP30 and EP35 can playback NTSC, they will have PAL as default.

If you play a R1 DVD that is encoded with RCE, you will get an error message like: 'This disc is not formatted to play in this region'. You will then need to enter the RCE hack, which can be found here.


Disclaimer
****************
By downloading the firmware files you agree that you fully understand the potential, like with any firmware update, to "brick" the player and are happy to attempt this firmware update at your own risk.
****************

UPDATE !!!

Link to the firmware files can be found here: http://www.avforums.com/forums/8590510-post787.html
 
Last edited:

Soundwave

Distinguished Member
Hey all,

Need some help if possible.

my EP30 seems to have lost Region free goodness :(

I've checked & my firmware is 4.0/2.0 & everything was fine up until this week went to watch a Region 1 movie tonight & it now tells me that the disc isnt for this region :(

Any idea's why it might have dropped compatability??

Thanks in advance

Neil
 

Viking61

Well-known Member
Try reinstalling the dirty firmware. Then re-upgrade to version 4.0 afterwards.

Btw.
What is the exact error message? Are you sure it's not the RCE error? If you get an error message like: 'This disc is not formatted to play in this region', then you have to enter the RCE hack by the remote.
 
Last edited:

Soundwave

Distinguished Member
Try reinstalling the dirty firmware. Then re-upgrade to version 4.0 afterwards.

Btw.
What is the exact error message? Are you sure it's not the RCE error? If you get an error message like: 'This disc is not formatted to play in this region', then you have to enter the RCE hack by the remote.
Lol was just about to post that it's the RCE problem...just tried my R1 20th Anniversary Transformers: The Movie & it plays fine.

Sorry about that :(

Just out of curriosity whats the RCE hack???
Didnt know one existed.

Thanks for the post anyway :thumbsup:
 

Viking61

Well-known Member
Just out of curriosity whats the RCE hack???
Didnt know one existed.
Look at the end of the first post in this thread. Just above the disclaimer.
 
Last edited:
M

Miodbadger

Guest
Apologies for this.. I'm trying to do the excellent hack. I've downloaded the two ISO files and I'm having great trouble copying the ISO files to CD.

Should I be able to see the ISO files on a burnt CD? The last bit of software I used was "CD recording wizard", and it seemed to do all the right things, but there appears to be nothing on the CD when I check under Properties? Is this normal with .iso files?
 
M

Miodbadger

Guest
....and more! Has anyone got the EP30 Dirty1 and 2 discs they no longer want? I could paypal the costs or contribute to your charity, as wished.

Many thanks, Modbadger
 

Viking61

Well-known Member
Apologies for this.. I'm trying to do the excellent hack. I've downloaded the two ISO files and I'm having great trouble copying the ISO files to CD.

Should I be able to see the ISO files on a burnt CD? The last bit of software I used was "CD recording wizard", and it seemed to do all the right things, but there appears to be nothing on the CD when I check under Properties? Is this normal with .iso files?
Be sure to burn the iso file to the CD as an image. You are not supposed to see anything on the CD after burning, but the Toshiba player will read it.
 

SuZee

Novice Member
have lost my region free ness!!! are these dirty 1 & 2 still around??
 

Viking61

Well-known Member
have lost my region free ness!!! are these dirty 1 & 2 still around??
Are you sure it's not a RCE protected disc you try watching? Then you will need the RCE hack also. What is the exact error message you get?
 

SuZee

Novice Member
Hi Viking

All the message says is Region error .... :rolleyes:
 

Viking61

Well-known Member
Hi Viking

All the message says is Region error .... :rolleyes:
At the bottom of the first post in this thread you will find a link to the dirty regionfree iso files. Just run the installation again, and remember to (re)apply version 4.0 afterwards.
 

SuZee

Novice Member
Thanks Viking

I am trying to download from that site, but no joy ... will keep trying. My fw version is 1.1 - kinda out of date!! hehe

Do you know if the links should still work?? :)
 

Viking61

Well-known Member
As far as I know the links should still work. I can see the files listed, so I suppose they are there.

If you are on firmware version 1.1, then you have never been regionfree on that player. The regionfree firmware is based on version 1.3.
 
M

Miodbadger

Guest
Hi Viking 61 - my player is already updated to V4.0 firmware. Do I need to do anything different to the steps you've already posted to update to all regions?

Would I finish the procedure by "re-upgrading" to V4.0?

Apologies if this is a dumb question!
 

Viking61

Well-known Member
Hi Viking 61 - my player is already updated to V4.0 firmware. Do I need to do anything different to the steps you've already posted to update to all regions?

Would I finish the procedure by "re-upgrading" to V4.0?

Apologies if this is a dumb question!
No need to do anything extraordinary. Just follow the steps as described in the first post. Yes, it is advised to "re-upgrade" to V4.0 afterwards, or else you will be on V2.5.

No apologies needed. :)
 

SuZee

Novice Member
As far as I know the links should still work. I can see the files listed, so I suppose they are there.

If you are on firmware version 1.1, then you have never been regionfree on that player. The regionfree firmware is based on version 1.3.
Hi Viking

Well, the region free went well as per instructions, just upgrading fw as I type ... been on Step 4/4 for a while ... is that right??

Thanks for all your help so far!! :clap:
 

Viking61

Well-known Member
Step 4/4 always takes some time. Usually 20 - 25 minutes. Just let it finish by itself, and whatever you do don't turn it off manually prematurely.

Be sure to download the RCE hack also. In case you have some RCE encoded region 1 DVDs.
 

SuZee

Novice Member
Viking

What can I say ... everything is working great! Not long after I posted, the fw completed, and have been able to watch R1 and a RCE encoded film.. I know you've had loads of thanks, but have to add mine - for replying and patience!!

Much appreciated!!!! Again!!!! :thumbsup:
 

gaz2810i

Well-known Member
This may be an odd Question but I have just installed a a 7.1 speaker set-up and I was wondering how you know (or if there is a way) if the crossflash procedure has taken place. My player is region free and I did this many years ago but I can't remember if I did the cross flash or not. Is it work simply doing the whole thing again or is it a risk I shouldn't take. Also what 7,1 HD DVD movies are there out there :thumbsup:
 

Axkman

Standard Member
I am trying to update my ep30 (with ep35 regionfree firmware) back to ep30 firmware. However, when i load ep35_dirty1 disc, it doest show the setup1_4, setup2_4 steps, it goes right from "ver up" to "1004050". I let it stay that way for atleast 10mins.

Then when i have the player disconnected from mains for 10 secs, and fire it up again, the screen doesnt stay blank. It just starts up as normal.

When burning the ep35_dirty1.iso with imgburn, strangely at label it says "HDEP30KTE - FW 1,300".
With the ep35_dirty2.iso disc that label said "HDEP35KTE - FW 1,300", so i suspect the ep35_dirty1.iso you provided is accidentely an ep30_dirty1.iso disc.

Could someone verify this? Where you able to flash your ep35 firmware back to ep30 firmware with the ep35dirty_1.iso and ep30dirty_2.iso discs?

Thanks!
 

Viking61

Well-known Member
If you push 'Display 1 9 5 Display' on your remote, what is shown as 'Machine Code' and 'Package Version'?
 
Last edited:

Viking61

Well-known Member
I suppose you are 100% certain that it really is EP35-dirty1 that you have downloaded and burned to the CD, so it should work.

I would suggest that you try running the "clean" EP35 regionfree firmware:
HD-EP35 Ver1.3 regionfree.iso - Windows Live

This will downgrade the firmware to version 1.3. After that you can try again with the EP35-dirty1.
 

Axkman

Standard Member
Tried flashing that ep35 v1.3 iso, it ends with "1004050", screen stil showing "updating do not power off".

Version check after flashing still shows machine code ep35kte and package 4000

Now i probably have to mention that my ep30 player ALWAYS enters "1004050" when i try to change settings in the setup menu, or when the unit goes in standby/poweroff.
 
Last edited:

Viking61

Well-known Member
Sounds like your player has an error that keeps you from changing anything. You could try doing a factory reset by pressing Display, 7, 0, 1, Display on the remote. I don't know if it will help, but maybe you will be able to enter the Setup menu afterwards.
 

Axkman

Standard Member
I pressed the code, after the player displayed "Goodbye" and next it showed "1004050".
Still not able to store changes in setup or use any firmware update iso.

I opened the player to see if there might be a battery to store settings but i couldn't find one.

Is there any hope for my player or is it ripe for the trash bin?
 

Viking61

Well-known Member
Well, I suppose it still plays HD DVD and DVD discs. It is regionfree and on version 4.0. So no need for the trash bin yet. The only thing you are not able to do is to change the firmware or go into the setup.
 

Similar threads

Trending threads

Latest news

Sharp unveils 30-inch rollable OLED TV
  • By Andy Bassett
  • Published
ATC launches C1 Sub Mk2 active subwoofer
  • By Andy Bassett
  • Published
Best Home AV Products 2019 - Editor's Choice Awards
  • By Steve Withers
  • Published
Disney+ unveils Maclunkey cut of Star Wars: A New Hope
  • By Andy Bassett
  • Published
Disney+ subscribers experience launch day technical jitters
  • By Andy Bassett
  • Published

Latest threads

Top Bottom