Toshiba 32Z33B picture problems

Discussion in 'General TV Discussions Forum' started by Barbs, Dec 27, 2006.

  1. Barbs

    Barbs
    Active Member

    Joined:
    Oct 2, 2006
    Messages:
    457
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Belfast
    Ratings:
    +20
    Hi,

    I hope someone can help me with a problem that my father-in-law has with his Toshiba 32Z33B CRT (this forum has never let me down so far :smashin: ).

    The set is about 3 years old and the following pictire problems are happening:
    - the picture is skewed to the left, cutting off some of the screen
    - there are some vertical green lines running down the left hand side
    - when you display the sky tv selection, it looks as if it is getting sucked into the middle of the screen!! The best way I can describe this is that it is like the credits at the start of Star Wars!

    I have searched on the forum and although alot of people state that this is a DFS module problem I am not sure that it is the saem issue or that this happens to this model. I have also heard this issue referred to as the "east/west" problem.

    Can anyone help? Is this a Toshiba engineer job (I tried them, but could not get through!)

    Thanks,

    Barbs.
     
  2. JayCee

    JayCee
    Distinguished Member

    Joined:
    Jan 20, 2004
    Messages:
    23,629
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Lanarkshire
    Ratings:
    +2,550
    You're right...this chassis is different and doesn't use the same DFS module.

    The technical term is a "Pincushion" problem probably in the East/West circuit.

    They're likely to be closed for the holidays but really you should be contacting the place you bought it from for service (I presume it's out of guarantee...unless you bought an extended warranty)...certainly if you contact Tosh they can probably recommend a Toshiba approved service in your area.
     
  3. Barbs

    Barbs
    Active Member

    Joined:
    Oct 2, 2006
    Messages:
    457
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Belfast
    Ratings:
    +20
    Thanks JayCee :smashin:

    I have been trying the Tosh service centre - they are open but not answering...so it looks as though I will have to wait.

    I wonder if anyone else has had this problem? I'd be interested to see if there is a known issue and a known fix for it.
     
  4. Barbs

    Barbs
    Active Member

    Joined:
    Oct 2, 2006
    Messages:
    457
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Belfast
    Ratings:
    +20
    Update on this one - the tv has now died!!!!

    Although we can get power (i.e. the red light is on the front on the set) there is NO picture!!!! Jasus - so much for reliable Toshiba kit!!
     

Share This Page

Loading...