Toshiba 27WLT56B - Unwatchable picture

VOT Productions

Standard Member
Hello everyone, this is my first thread on AVForums.
A week ago, I have bought a second-hand Toshiba TV. When I started it up the first time it was working great.
Then, since the TV has a DVI port, I've decided to connect my computer to it.
This is where things went downhill.
It worked fine for a couple of minutes, then the problem started. Picture was distorted.
I try again. Same result.
A couple of hours later, I try it again. It worked for another few hours, until I started up Minecraft and played it a couple of minutes. Same result.
Then I connected my Wii. Same result, instantly. Note: There was a 2-second delay before the bad picture started.
Now today, if I connect my Wii or monitor, I will get a 2 second delay and a picture problem. If you are lucky, the Wii won't distort for a few seconds. If you are unlucky, you might get the bad picture problem as soon as the TV starts.
I think the TV isn't so badly broken as it displays the correct picture for 2 seconds.
Anyway, here is what I tried:

Different wires.
Different rooms.
Different TVs (my Sharp works fine.)
TV switched off from the mains for the night.

Now, to describe the distortion:

There are 4 types.

1. Inverted picture ex. white is black. With sharpness at max and a pink/redish tint with 4 images of the same source (it happens nearly every time).

2. Normal picture with 2 images of the source. Very rare, happened only once and it lasted for 5 seconds.

3. Can't see picture at all, 2 areas with white pixels with a black/red background.

4. Above with snow.

Help me :lease:

Don't upset him -> :cool:

PS. Some one link me the rules... I can't find them!
 

The latest video from AVForums

Podcast: Large Screen HDR TV or Projector For Home Cinema + Best of the Month
Support AVForums with Patreon

Top Bottom