Tosh 420 owners-read this

Discussion in 'Blu-ray & DVD Players & Recorders' started by redmax, Dec 30, 2002.

  1. redmax

    redmax
    Active Member

    Joined:
    Sep 13, 2002
    Messages:
    1,059
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    ESSEX, UK
    Ratings:
    +47
    I recently took delivery of my Toshiba SD 420E and after setting it up got into some serious veiwing of my DVD's.
    I was viewing on a 15" LG LCD monitor (RE-15LA30) while I completed work on my home cinema project.
    It was whilst watching Mulan that I noticed the ghost image of a box in the top right hand of the screen.
    The image is of the box that appears when you use the function keys and confirms the key pressed eg play, rew,ff etc.
    What bothered me was that the ghost seems to be present all of the time during viewing.I checked other discs and it is present on all discs at all times.
    I couldn't believe that Toshiba would produce a fine player with such a terrible flaw so put it down to the LCD monitor.
    I have now finished work on my main set up using a Seleco SVP 400 crt projector and 2400mm screen and guess what? The image is still there!!!!.
    Has anybody else got this problem or have I got a dud player?
    I haven't contacted Toshiba technical yet because I know I'll get more sensible answers on this forum!!!
    If it turns out to be integral to the player then have I got the right to demand a refund cos I aint 'appy.
     

Share This Page

Loading...