Tosh 37WLT66 : are these "features" or "failures"

phanco

Established Member
Joined
Feb 18, 2004
Messages
703
Reaction score
36
Points
203
Location
Edinburgh
Got my 37WLT66 a couple of weeks ago, but have had 2 instances of each of the following ...

Issue 1
On two occasions, taking the TV out of standby, the screen has not come on (althouth the sound comes through the speakers). Nothing I can do will persuade the LCD panel to kick into life. However, pull the mains plug for 30 seconds (until the red standby light goes off to ensure there is no power at all), plug back in and all is fine.

Issue 2
On two occasions, I have experienced "horizontal snow" - picture interference of white dots all over the screen (but with an obvious horizontal "motion". Cured by putting the TV into and out of standby.

Both of these are easilly cured, but having both happen twice in the first 3 weeks I am obviously concerned about the long term prospects for the TV. I bought online as well (PRCDirect.co.uk) so dont know what the score is for faulty goods - I hope I'm not expected to RTB !

Anyone seen/heard of these symptoms elsewhere ?
 
Hi phanco,

I haven't got this set myself but my Phillips LCD tv was suffering from your Issue 1.

Got an engineer out on it and was told that one of the PCB's was faulty, and as Phillips didn't release it as spares had the unit changed.

I now have a Tosh 37WLT68 (arrived today) and it's fantastic.

Perry
 
I hope your wrong ! - but I guess Ill have to call PRC in the morning...
 
Got my 37WLT66 a couple of weeks ago, but have had 2 instances of each of the following ...

Issue 1
On two occasions, taking the TV out of standby, the screen has not come on (althouth the sound comes through the speakers). Nothing I can do will persuade the LCD panel to kick into life. However, pull the mains plug for 30 seconds (until the red standby light goes off to ensure there is no power at all), plug back in and all is fine.

Issue 2
On two occasions, I have experienced "horizontal snow" - picture interference of white dots all over the screen (but with an obvious horizontal "motion". Cured by putting the TV into and out of standby.

Both of these are easilly cured, but having both happen twice in the first 3 weeks I am obviously concerned about the long term prospects for the TV. I bought online as well (PRCDirect.co.uk) so dont know what the score is for faulty goods - I hope I'm not expected to RTB !

Anyone seen/heard of these symptoms elsewhere ?

I have had one of these sets now for over a month, and I don't get any of the issues you have.

I will get this checked out.
 
I have had one of these sets now for over a month, and I don't get any of the issues you have.

I will get this checked out.

Thanks - think I'll give Toshiba a ring first ...
 
Phanco........

So you don't get the buzz from this set????
 
Phanco........

So you don't get the buzz from this set????

nope - no buzz on any backlight setting !!

PRC agreed to pickup in the new year (dont lose telly over xmas for what is an intermittant fault) and agreed I was reporting within 28 days so I wasn entitled to replacement...

I bet the replacement has both dead pixels and buzzing backlights !!
 
Phanco... I've been using the 37WLT66 for a couple of months now and have had no problems except that my Dad's now kicked me out of the front room and I've had to take my 360 upstairs :(

Now I need to decide which TV to buy for myself.. I'm in the process of buying a house so not sure whether to get the TV now or wait a while. Has anyone seen both the 32WLT66 and the 68 running side by side? Is the 68 worth the extra money?
 

The latest video from AVForums

RESTORATION vs. REVISIONISM: At what point do 4K video and audio 'upgrades' cross the line?
Subscribe to our YouTube channel
Back
Top Bottom