Tosh 36ZP38 has no Red in the picture. Why?

Discussion in 'General TV Discussions Forum' started by StuH, Oct 26, 2005.

  1. StuH

    StuH
    Standard Member

    Joined:
    Sep 12, 2005
    Messages:
    26
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Location:
    Winchester
    Ratings:
    +0
    My two year old Toshiba 36ZP38B has suddenly started to display green/yellow and blue only on the screen. When first switched on, it may display a normal RGB full-colour picture, then suddenly drop the red component after a couple of minutes. Conversely, the normal picture my restore itself after the TV has been on for about 45 minutes. What's happening? Is this fixable without taking a second mortgage?? :rolleyes:
     
  2. JayCee

    JayCee
    Distinguished Member

    Joined:
    Jan 20, 2004
    Messages:
    24,142
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Lanarkshire
    Ratings:
    +2,651
    It could be a dry joint or...worst case scenario...faulty crt.
    You won't know until you've had it looked at by an engineer.
     
  3. StuH

    StuH
    Standard Member

    Joined:
    Sep 12, 2005
    Messages:
    26
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Location:
    Winchester
    Ratings:
    +0
    JayCee, Thanks for this.
    Called an Engineer today and was told it could be a faulty DFS unit. (whatever that is?)
    TV is being taken to the Workshop next Wednesday. Large van and two men calling to collect it!!

    Follow up: Diagnosed as a faulty DFS unit. Replaced, cost £144 + VAT. Picture now perfect again!
     

Share This Page

Loading...