Tosh 330 Problem

Discussion in 'Blu-ray & DVD Players & Recorders' started by Tesla, Jan 28, 2004.

  1. Tesla

    Tesla
    Active Member

    Joined:
    Dec 9, 2003
    Messages:
    940
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Bristol, UK
    Ratings:
    +32
    I got a Tosh 330 from Amazon at Xmas. It had a serious fault (overheating i guess) that after a while loads of horizontal lines would appear across the screen.

    They have sent me a replacement...

    When i first got it it would not switch on. The RED LED changed to green, no activity on the LCD the TV would switch to AV but no signal was received. The DVD player would then switch off.

    This problem just went and I was able to switch on the DVD player.

    However, the problem has now returned.

    I was just watching a bit of matrix reloaded and then switched off the dvd player.

    Just tried to switch it on and i get the problem described above.

    How can i resolve this issue. Or will i have to send it back AGAIN!

    \\Chris
     
  2. Mylo

    Mylo
    Well-known Member

    Joined:
    Mar 13, 2003
    Messages:
    5,541
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Ratings:
    +372
    Send it back mate, it's the only solution. Sometimes these things just happen.

    Cheers, Mylo
     
  3. Tesla

    Tesla
    Active Member

    Joined:
    Dec 9, 2003
    Messages:
    940
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Bristol, UK
    Ratings:
    +32
    Its decided it wants to switch on now.

    It looks like it has been opened. Is this to do with it being region-free?

    \\Chris
     
  4. Mylo

    Mylo
    Well-known Member

    Joined:
    Mar 13, 2003
    Messages:
    5,541
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Ratings:
    +372
    No I believe the Multi region hack is done using a CD-ROM of some sort. I know it's a pain but I would still send it back. Electronics don't normally cure themselves, not permanently anyway.

    Cheers, Mylo
     
  5. Tesla

    Tesla
    Active Member

    Joined:
    Dec 9, 2003
    Messages:
    940
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Bristol, UK
    Ratings:
    +32
    Yep. I'm gonna email amazon again.

    They did re-imburse my postage costs last time so its just hassle really.

    \\Chris
     

Share This Page

Loading...