tosh 220 problems - help please

Discussion in 'Blu-ray & DVD Players & Recorders' started by spark, Oct 7, 2002.

  1. spark

    spark
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Just bought my Tosh 220.

    Got it home, put Blade II that I rented from Blockbuster in.

    All looking and sounding great, but about half way thru it jumped a bit, then ground to a halt. Wouldn't FF or rewind, or play or anything.

    I stopped it, checked the disc and it looked to have a big dirty fingermark on it, which I cleaned off. It then seemed to play fine.

    Is this what dirty DVD's do, or is it the player? Or is it Blockbusters crappy DVDs?

    Since it's the first one I've played on it, I don't really know what these symptoms mean.

    Anyone?
     
  2. gringottsdirect

    gringottsdirect
    Active Member

    Joined:
    Jan 11, 2002
    Messages:
    2,897
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    71
    Location:
    50 Rue St Georges, Paris.
    Ratings:
    +29
    They can yes. I always give rentals a clean before popping them in my player.
    Try some more and get back to us :) .
     
  3. spark

    spark
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks for that.

    I think it was just a dirty disc.

    Well pleased with the player in general - one other thing tho:

    When I tried to pay an mp3 disc, it only seemed to see the first 20 tracks. Is this because I put then on the CD in separate folders and it can only read the first one?
     

Share This Page

Loading...