TomTom XL One

happyhotspur

Active Member
My tomtom has all of a sudden gone haywire. I hadn't used it for several weeks and yesterday when I tried to use it it would not work, I assumed the battery was completly flat so have been charging it up for nearly 24 hours via my computer. Now after carrying out a reset, it switches on asks me to set the language etc until it reaches the voice option, I select the normal female voice and then the machine hangs then switches itself off then starts the same process again.

I have carried out the recommended reset, and tried to use the tomtom via my laptop but although it carries out a download check, when I try to operate it via the computer it says I am missing a download, when trying to carry out the download I get an error message telling me that an emulator is missing off my laptop.

I have contacted Tomtom, but not heard back, does anybody have any idea's what has gone wrong or what i can do to get it repaired. The machine is only two years old and has never given me a problem until this happened.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom