Time to replace HTPC???

shailesh1

Standard Member
Hi all,

I'm looking for some help/suggestions if anyone has any ideas. Just spent all weekend trying to figure out why my HTPC has decided to play 3D movies with a lot of pixelation. At first, I thought it might be a corrupt movie, but all my older 3D movies are doing the same thing. To make matters worse, after playing around with some of the settings, my Atmos has stopped working.

I restored to an older backup from a few days ago but no avail, 3D is still all choppy and pixelated and I can't get Atmos to display on the front panel of the receiver as it has been doing.

I have an Aorus Z390 Pro Wifi Rev 1.0 Mobo with i3-8100 CPU running via Intel UHD 630 Graphics card. The receiver is the Denon AVR-X6400H.

I am using DVDFab Player 5, which has been working like a charm and playing 3D movies with Atmos without any issues. I have even got some demo clips from Dolby website, which used to display Atmos on the display when playing them with DVDFab player 5.

Even PowerDVD 15 was working fine until just recently. I have tried the 3 settings:

1. PCM decoded by PowerDVD
2. Non-decoded Dolby Digital/DTS to external device
3. Non-decoded high definition audio to external device

I have updated all the drivers, BIOS, changed refresh rates on the graphics settings etc. and now I am completely stuck.

Apart from completely wiping the HTPC and starting from scratch, is there anything else I could try? I suspect a Windows update has caused my issues but I have no idea when and which one.

Is there a good alternative to a HTPC that will play ISO from a NAS, with 3D and Atmos?
I did read about the Oppo UDP-203 while ago but not sure if this is still a good option.

Sorry for the long post, it has been a long, exhausting weekend and I am no closer to resolving this issue

Shailesh
 

The latest video from AVForums

Podcast: LCD TVs for Movies, Physical Discs?, RIP Ennio Morricone, AV & Movie news, B+W Matt Damon
Top Bottom