Thomson DTI 6300 stopped working, red light flashing fast. help!

K

kt-claire

Guest
Hi, I have a Thomson DTI 6300-16 box. I bought it from TUTV over a year ago and it has been nothing but trouble. I've just come back from a few days away to find the box frozen, nothing new! but this time when I unplugged it and plugged it back in all I'm getting is a rapid flashing red light and nothing happens. Can anyone tell me why this might be?
 

beef2006

Standard Member
Hi, I have a Thomson DTI 6300-16 box. I bought it from TUTV over a year ago and it has been nothing but trouble. I've just come back from a few days away to find the box frozen, nothing new! but this time when I unplugged it and plugged it back in all I'm getting is a rapid flashing red light and nothing happens. Can anyone tell me why this might be?
A belated reply whic might help others searching for issues with Thomson DTI6300. These boxes do seem to have their fair share of problems but I managed to improve one which had problems by the simple method below.

I bought one of these for a relative at Christmas...and after a few months they reluctantly told me that it was playing up in the ways you describe. I phoned the retailer...and was put through to a helpline...and I expected the worst when a girl on the end of the phone suggested we try resetting it to factory defaults. I assumed she was clutching at straws. However I have to admit that since resetting to factory defaults, its been perfectly behaved so far.

I cant claim to understand why it fixed it. Certainly when you reset these to factory defaults you lose all your existing recordings...so maybe it reformats the hard disk in the process ? And maybe that fresh format identifies occasional bad sectors on the hard disk and marks them out of use or something.

I probably wouldnt recommend buying one of these. In my opinion there are better ones out there for similar money now...but if you already have one and its freezing then resetting to factory defaults (unfortunately you will lose any existing recordings) might improve it. It worked for me.
 

tommyturnip

Member
Hi, I have a Thomson DTI 6300-16 box. I bought it from TUTV over a year ago and it has been nothing but trouble. I've just come back from a few days away to find the box frozen, nothing new! but this time when I unplugged it and plugged it back in all I'm getting is a rapid flashing red light and nothing happens. Can anyone tell me why this might be?
Your Thompson has ROLFED (Red or Orange Light Flashing Equals Death), there is a process for recovering the Thompson if the light is steady but flashing equals broken.

The same happened to me two weeks ago but my box was only 10 months old, luckily Argos just gave me a straight refund.
 
Last edited by a moderator:

finetuneplus

Standard Member
Hello there, try this,
1.power out for 20 seconds,
2. power on while holding in std by button on front panel.
3. when any light comes on press - up, down , left right, on front panel, within 5 seconds.
The machine will return to std by after about a minute.
4. switch on normally.

This is the all format code for most of the Thomson pvr's.


If this doesnt cure it, the Hard Drive may be faulty.
 

triumph1000

Standard Member
There is a known fault with the power supply where the electrolytic capacitors fail (about 8 of them!!!) just as the warranty expires! or sooner:mad:. This WILL cause pixelations, missed recordings and any other problems which are mentioned on this site. If you can handle a soldering iron try Satcure satellite dish LNBs digital TV aerial information. This site is a mine of info:),and order their repair kit for these boxes.
 

The latest video from AVForums

Podcast: Philips OLED+935 impressions, Denon AVC110 Review, Film Reviews, News and More...
Top Bottom