ThinQ not recognizing Fat32 action camera USB Drive anymore, won't reformat either.


Novice Member
I have an LG Nano ThinQ but I bought the year before last on Black Friday. The TV has been far from perfect because the HDMI audio sync fails when switching inputs and watching YouTube.

Yesterday I tested out my new Akaso Brave 7 action camera. For the camera storage I purchased a SanDisk Extreme Pro micro SD card and tested it; read speed of 98 and a write speed of 86. The camera storage is formatted to Fat32.

Since this LG TV is supposed to read Fat32 and NTFS I didn't think there would be any issue connecting my camera to the TV, and upon connecting it for the first time, the TV asked me if I wanted to reformat. I chose No, and then when I went to my input selection area, low and behold was my action camera USB storage. I thought to myself hell yes, it works like it should. I proceeded to watch my various videos that I recorded. 4k all the way down to 720 just to test it out.

The next day I decided to do the same thing except this time it would not recognize the camera drive. I switched to every USB port. I tried to replicate everything I did the day before. I even cleared off the SD card to have it reformatted by the TV and the TV failed to reformat it. That makes sense though because the TV was going to reformat it for NTFS instead of Fat32.

What's really interesting is that before I cleared off the data to prepare the SD card for a reformat, I noticed that there was a LG TV content folder in the storage at the root.

Can someone please help me understand what the hell is going on?? Why did this work one day and then not the next? Why did the TV put a folder on my card when I didn't allow it to do a reformat the first time? Why did it only work one time? This doesn't make any sense whatsoever.

I repeated the steps after reformatting the card via the action camera, and still no dice.

I just don't get it. If an LG TV is supposed to read Fat32 why the hell isn't it reading a Fat32 USB drive?

I hope someone can help me and please shed some light on what is going on, what I'm missing if anything. This is really really strange.

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom