• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

the mummy ps3 problem

evening
i watched the mummy on blue ray last night but fell asleep and missed half of it.
So i thought that i would watch the rest now but it refuses to play the small loading box appears then goes then it hangs, if i press display it says title-1 chapter 1. the time counter is at zero i cant skip or press the top menu button (not allowed)
Iv switched the ps3 (uk) of at the mains, ejected the disc, theres not a single mark on the disc trie diffrent bluerays that all play after it its just not having it.
Anyone else had a similar problem to this and got any pointers

cheers bri

otherwise its the mummy returns for my first viewing of the night


just tried the mummy returns does the same and also the 40 year old virgin all 3 are universal titles oh joy got dawn of the dead 2004 aswell
just updating firmware to 2.43
although 2.50 is due anytime lol

see what happens after the update

still no go first 4 are all usa
tried doomsday uk version wont play either looks like a universal problem for me
also cleared the java cache :(
 
Last edited:
ok solved it rather bizzare

i have a 60g ps3 and always have 2 flash drives plugged into the usb ports,i plugged a 3rd 8 gig into the 3rd usb port today and that stopped
the universal titles from working removed it and they play :eek::eek::eek:

well hows about that lol
 

The latest video from AVForums

SVS Prime Wireless Pro Powered Speakers - Review Coming Soon
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom