1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The blue RCA Component connector came out of my 32ZP48

Discussion in 'TVs' started by GreatKingBowser, Sep 16, 2005.

  1. GreatKingBowser

    GreatKingBowser
    Standard Member

    Joined:
    Dec 16, 2004
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    So I plugged the DVD in using some Monster component leads, now these things as you're all aware are meant to be pretty tight, trying to remove said cable from the back of the TV resulted in the blue RCA connection bit coming out the back of the TV along with the cable!

    I've only had the TV 2 days, eurgh.

    Anyone got any idea how to plug it back in? Gonna give it another go in a minute.
     
  2. GreatKingBowser

    GreatKingBowser
    Standard Member

    Joined:
    Dec 16, 2004
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Haha, so I sorta got it re-connected, but it's definitely protruding further out than it's red and green counterparts, and it'll come back out again if you remove the cable as it's still loose. Possibly might leave as is until I encounter any other problems, touch wood I don't though.
     
  3. longy

    longy
    Active Member

    Joined:
    Jul 7, 2005
    Messages:
    362
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Canterbury/kent
    Ratings:
    +21
    if its still under warranty i would get some one to fix it
     
  4. GreatKingBowser

    GreatKingBowser
    Standard Member

    Joined:
    Dec 16, 2004
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Heh, 2 days old. Paid PRC for 2 year on-site warranty, I guess the first year is manufacturers, can I still get PRC to send someone out?
     

Share This Page

Loading...