Quantcast

The 'black screen on input switch' SkyQ thread

stripeyjoe

Active Member
Looks like lots of people have been discussing this under the firmware thread so have created a new thread for the subject.

This started happening to me last week, whenever the AVR input is switched away from Sky Q then Sky box needs a power-cycle to output again when switching back to that input. I see someone else says switching Eco off helps, I think this started when I switched that option on but, having switched it off again, am no better off.

I wonder whether it is specifically happening with Denon AVRs or there are other users affected? Is it a handshake issue between the two units?

It's making the thing completely unusable especially with the rest of the family when they switch from game, apple TV or blu-ray back to the Q box.

Has anyone managed to fix this yet?

Thanks!
 

housley1979

Novice Member
Not restricted to Denon I'm afraid, I have a Sony 1080 and it's the same story. Also from reading the long thread on sky forums (which is now locked by the way) people with soundbars and people who even have Q connected directly to the TV have the same issue.

The only workaround I've found is to ensure you put the Q in standby before switching inputs on your AVR, then switch back to Q input before turning the Q box back on. I'm ok with this solution to a certain degree, but it's still really annoying as I use a Harmony remote which is effectively redundant while this issue persists.

It is a handshake issue, and it's definitely with the Q box not other equipment. From reading the sky thread people have reported it to sky, they've sent out engineers and they've simply replaced the boxes - obviously to no benefit, but that's the routine they have to go through. So sky are aware of the issue, and are probably working on it, but possibly struggling to find a solution.
 

stripeyjoe

Active Member
So the routine to teach the family is...
1. Turn Sky Q to standby
2. Switch to apple TV/BluRay etc
3. when finished, switch input back to Sky
4. Turn on Sky Q box again
I'll try that to see if ti works.

Bit of a pain as we are so used to just turning a unit on and the AVR automatically switches to that input, also it's dead easy to turn on the apple TV just be brushing the remote, it's super sensitive to touch.

Let's hope they fix it as it is a PITA!

Ta!
 

stripeyjoe

Active Member
Despite leaving the above as instructions both mother and child were on iPads when I got in last night claiming the telly wasn't working!
Guess there is no point returning it if there is a design fault but it is really crap.
 

stripeyjoe

Active Member
Now, to add to the issue yesterday the sound started cutting out every minute or so, have tried changing the HDMI, switching Dolby + off, switching to 1080 output.
This is happening with both the sound coming via the Denon directly and via the TV with the Denon in pass through mode.
Have changed nothing, it just started doing it!
 

mo.dilwar

Active Member
So the routine to teach the family is...
1. Turn Sky Q to standby
2. Switch to apple TV/BluRay etc
3. when finished, switch input back to Sky
4. Turn on Sky Q box again
I'll try that to see if ti works.

Bit of a pain as we are so used to just turning a unit on and the AVR automatically switches to that input, also it's dead easy to turn on the apple TV just be brushing the remote, it's super sensitive to touch.

Let's hope they fix it as it is a PITA!

Ta!
The one and only true fix currently is to get Sky to swap out your Sky Q main box with a V1 (the one with an internal power supply) model Sky Q v2 and LG OLED problems **possible fix**
 

AidenL

Well-known Member
I have this issue, and I have a V1 box actually, so not sure if that’s the fix we need either to be honest.
 

bustamills

Active Member
I`m, in the same boat ,LG Oled, Denon receiver and Sky Q , I only got the Denon last week and before that a Pioneer which didnt have this problem , but I still think its a Sky problem rather than a Denon problem ,but reading on the Sky forums its widespread and when people have contacted Sky , Sky claim they have not heard any problems about the black screen, and all they do is send someone out to switch boxes
 

mo.dilwar

Active Member
Switching boxes to V1 model “fixes” the issue. Not had a reoccurrence since my Sky Q was swapped back to a V1 model 2 weeks ago.
 

interbear

Active Member
So the routine to teach the family is...
1. Turn Sky Q to standby
2. Switch to apple TV/BluRay etc
3. when finished, switch input back to Sky
4. Turn on Sky Q box again
I'll try that to see if ti works.

Bit of a pain as we are so used to just turning a unit on and the AVR automatically switches to that input, also it's dead easy to turn on the apple TV just be brushing the remote, it's super sensitive to touch.

Let's hope they fix it as it is a PITA!

Ta!
Unfortunately this routine didn’t work for me. Still got the black screen issue.
 

waveydavey13

Active Member
Our box has just updated to new firmware...... Q090.000.71.00L.

Possibly a fix for this issue?

I've noticed the scheduled recordings tab is back in the main recordings section again instead of in the manage sub-section.
 

mo.dilwar

Active Member
Our box has just updated to new firmware...... Q090.000.71.00L.

Possibly a fix for this issue?

I've noticed the scheduled recordings tab is back in the main recordings section again instead of in the manage sub-section.
Wonder if it includes any other charges other than bug fixes.
 

Nobbler

Distinguished Member
I now leave my Sky Q V2 box on all the time. I have no idea what it's doing to my bill and Sky can take the blame for me destroying the planet but it works 100% of the time.
 

TJT1

Well-known Member
IIRC its about 30W, so all week is about 5kWh at your unit cost. This equates to about 262kWh (units)/year. @ say 13p/unit, that's about £34/year. (and about 160kg of CO2 to appease the green brigade)
 

stripeyjoe

Active Member
Still happens from time to time, mainly when my daughter is watching YouTube kids via the Samsung app.
Had a Sky guy come out and swap the box, this fixed the sound cut out issues I was having.
 

The_Vindicator

Active Member
I now leave my Sky Q V2 box on all the time. I have no idea what it's doing to my bill and Sky can take the blame for me destroying the planet but it works 100% of the time.
Am I right in assuming that leaving the Sky Q box turned on when changing inputs does not result in the black screen issue when switching back?
 

The_Vindicator

Active Member
That's correct yes. Mines been left on for about a month
Thanks, I've currently got my Harmony activities set to turn off the SkyQ box first when switching activities and turn it On last when switching back.

If this fails I'll try leaving it permanently on.
 

Nobbler

Distinguished Member
I tried that and to get it to work 100% of the time, there needs to be a delay of 20 seconds before the Sky box comes on.
 

stripeyjoe

Active Member
I get the issue if the Q box is switched on when the input is changed, especially if it’s on and, when I turn on the AVR, it’s not on the Q input and I change it.
 

The_Vindicator

Active Member
So far all seems to be working as it should with my current activity setup, even got the Q090 firmware this morning for good measure.
 

waveydavey13

Active Member
Just out of interest..... Can an activity be setup on the harmony where by it doesn't turn the Sky Q box on and off at the start and end of that activity but still has all the buttons set for Sky Q while the activity is in use as it would normally?

I guess what I'm saying is can my existing activity be altered to just remove the switching on and off of the Sky Q box but keep everything else as it is now?
 

logiciel

Moderator
Make the on and off commands to be none.
 

The_Vindicator

Active Member
Just out of interest..... Can an activity be setup on the harmony where by it doesn't turn the Sky Q box on and off at the start and end of that activity but still has all the buttons set for Sky Q while the activity is in use as it would normally?

I guess what I'm saying is can my existing activity be altered to just remove the switching on and off of the Sky Q box but keep everything else as it is now?
you can set the SkyQ device not to turn off when switching activities in the device settings and you could also set up an activity to turn off the other devices off excluding the s
SkyQ instead of using the off button on the remote.
 

stripeyjoe

Active Member
This still seams to be an issue, I mostly get around it by switching the Q box off before switching inputs but occasionally forget and then I have to unplug its HDMI cable and plug it back in. This seems to kick it into life.
 

waveydavey13

Active Member
I stopped turning the Sky Q box off two months ago now and not had a single lockup since then.

Changed my Harmony activity to ignore powering the Sky Q box on or off.

Issue sorted. Now how do I manage to scrape together the extra 50p a year or so it costs to leave the box on 24/7??? :D
 
Last edited:

stripeyjoe

Active Member
I have the opposite problem, I have to switch the Q off before switching the input of my AVR to something else and only switch the Q back on again when the AVR input has been switched back to the Q box... If I don't do that the HDMI does not sync and I have to unplug and plug back in the HDMI cable.
 

RiseAbove

Active Member
I have the opposite problem, I have to switch the Q off before switching the input of my AVR to something else and only switch the Q back on again when the AVR input has been switched back to the Q box... If I don't do that the HDMI does not sync and I have to unplug and plug back in the HDMI cable.
Sounds like the issue I had, do you have a Sony str1080?

Sad to see it still hasn’t been fixed yet
 

TJT1

Well-known Member
I have the opposite problem, I have to switch the Q off before switching the input of my AVR to something else and only switch the Q back on again when the AVR input has been switched back to the Q box... If I don't do that the HDMI does not sync and I have to unplug and plug back in the HDMI cable.
How does your other half cope with all that? It would drive my Mrs to watch TV in the bedroom where we have a bog standard Freeview TV.
 

Similar threads

Trending threads

Latest News

Samsung's new AI ScaleNet codec supports 8K streaming
  • By Andy Bassett
  • Published
Netflix UK free trials come to an end
  • By Andy Bassett
  • Published
Sony update brings AirPlay 2 and Dolby Atmos support to select TVs
  • By Andy Bassett
  • Published
Cleer FLOW II headphones get Google Assistant
  • By Andy Bassett
  • Published
Top Bottom