1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tevion Home Cinema

Discussion in 'Home Cinema Buying & Building' started by Davemazo, Jul 24, 2005.

  1. Davemazo

    Davemazo
    Active Member

    Joined:
    May 29, 2005
    Messages:
    800
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Ratings:
    +9
    I`m new to home cinema and was looking for a cheapish home cinema system to go with my newly bought Tevion 32" LCD, Samsung HD850 DVD, Samsung DVDR-100e recorder and Sky+. I bought the Tevion system from Aldi in this weeks special offers because it seemed cheap and I liked the speakers already on stands making it easier to install. After reading this forum I gathered that the best way to connect audio is via optical cables so I was disappointed to find that the Tevion only had 5.1 phono connectors (one set) and an aux connection. Am I expecting too much at this price (£99.99) or is there something available with optical connectors at this price. I didn`t bother taking it out of the box when I saw this and took it straight back.
     
  2. Davemazo

    Davemazo
    Active Member

    Joined:
    May 29, 2005
    Messages:
    800
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Ratings:
    +9
    Doesn`t matter now. I`ve decided to go for the Yamaha RX-sl80 and nsp-240 speaker package, £200 at Peter Tyson. I think I`ve made a big mistake though, it`s so complicated and the manual makes no sense to me. The sub-woofer just seems to sit there and do nothing. Any help on this would be appreciated.
     
  3. rozzar

    rozzar
    Active Member

    Joined:
    Sep 29, 2002
    Messages:
    1,046
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    41
    Location:
    Braintree
    Ratings:
    +23
    have you gone into the amps menu and changed the bass setting to 'sub'. It may be switched to 'off, or none'
     
  4. Davemazo

    Davemazo
    Active Member

    Joined:
    May 29, 2005
    Messages:
    800
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Ratings:
    +9
    Thanks, sub is on yes maybe I just need to turn it up a bit. Are you using the RX-SL80? if so can you get the menu to display on the TV? All I get is a rolling screen and have to use the display on the amp
     

Share This Page

Loading...