1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Technical help with a Definitive Tech ProSub 100TL

Discussion in 'Subwoofers' started by chinesewhispers, Sep 22, 2004.

  1. chinesewhispers

    chinesewhispers
    Standard Member

    Joined:
    Jul 7, 2004
    Messages:
    127
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +1
    Hello all

    Could do with a little advice if possible.

    We had an electrical 'moment' recently that caused a problem with lighting. It seems that it may have crossed over to the rest of the electrics for a moment.

    My amp needed resetting as a result, and I noticed no life from my sub (Definitive ProSub 100TL). I checked the fuse on the back of the sub, and it was fried, so I changed it. Now when I power on the sub, it doesn't give the satisfying 'whoomph', but the little red light does come on. Altering the volume up/down makes no difference, nor does having/not having any input to it. Power goes to the back of the unit, but it seems it may not be getting any further.

    Can anyone suggest what it may be? And what action to take?

    Many thanks in advance, I really don't have the spare cash to get a new sub yet, and my system is lost without it.
     
  2. chinesewhispers

    chinesewhispers
    Standard Member

    Joined:
    Jul 7, 2004
    Messages:
    127
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +1
    In case anyone cares, I took my Sub back to the Leeds branch of Sevenoaks where I purchased it on 24th September.

    I explained the problem and they said they would send it off. The unit is 2 and a half years old.

    Got a call yesterday (6th October) to say the sub had been repaired by Definitive and returned to the store. Collected it later that day, took it home and it sounds as good (if not better) as new. Amp boards replaced under manufacturers warranty.

    So excellent work from Sevenoaks, and Definitive.

    Now I can watch those Star Wars films that people seem to be excited about :clap:
     
  3. Ian J

    Ian J
    Banned

    Joined:
    Aug 6, 2001
    Messages:
    25,529
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +4,905
    That is excellent service from both retailer and manufacturer who should both be commended.
     
  4. chinesewhispers

    chinesewhispers
    Standard Member

    Joined:
    Jul 7, 2004
    Messages:
    127
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +1
    Indeed, that is why I thought I should post and give it a mention.

    I may even write a letter to them!
     
  5. juniper

    juniper
    Active Member

    Joined:
    Dec 30, 2003
    Messages:
    1,850
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    48
    Ratings:
    +60
    Excellent news Mark - glad to hear that you got this resolved. I'm not sure that all manufacturers (or their agents - not sure exactly how Def. Tech. operate) would have been so "generous", assuming that you were out of warranty (and possibly even if you weren't!). I hear very good things about Def. Tech in general in fact - recently demo'd their Mythos One front three, and thought they were very impressive. Not heard their subs. tho', but with great customer service they can only be onto a good thing.
     

Share This Page

Loading...