1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tag's service department

Discussion in 'TAG McLaren Audio Owners' Forum' started by dougan, May 9, 2005.

  1. dougan

    dougan
    Active Member

    Joined:
    Jan 12, 2005
    Messages:
    439
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Devon
    Ratings:
    +10
    Hi,

    In March 2004 I purchased directly forom Tag a PA10 pre-amp and two 60P's power amps. On connecting it up I noticed that one of the BFA speaker cable sockets was broken. Luckly enough it has two sets of sockets, so I just plugged the cables into the lower sockets.

    I informed Mark Walker at Tag, who said it was either damaged in transit, or it was a faulty socket. He suggested that I either returned to them for repair, or they would send me a replacement socket for me to fit. I was not keen on opening my new amp and soldering a new socket, so I thought I would return it. Then the take over rumours started, so I held back while it was in progress.

    Would it be ok now to send it back to them? Do they still have a service department? I do not want to return it and then wait months before it is returned.

    Cheers

    Dougan
     
  2. GrahamMG

    GrahamMG
    Well-known Member

    Joined:
    May 8, 2004
    Messages:
    4,449
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    UK
    Ratings:
    +192
    Should be fine now, but ask how long it will take as they ain't that quick on turnaround yet.... Of course you could bring it to be for the price of a beer...! :D
     
  3. BigBilly

    BigBilly
    Active Member

    Joined:
    May 3, 2005
    Messages:
    1,093
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Edinburgh
    Ratings:
    +38
    IAG currently talking of 4 week turnaround period, spoke to them this morning

    Billy
     
  4. GrahamMG

    GrahamMG
    Well-known Member

    Joined:
    May 8, 2004
    Messages:
    4,449
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    UK
    Ratings:
    +192
    Anywhere near London W1? Do you have the replacement bit?
     
  5. roversd1

    roversd1
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    just use bare wire or spade connectors... much, much easier
     
  6. dynamic turtle

    dynamic turtle
    Active Member

    Joined:
    Mar 23, 2004
    Messages:
    1,501
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    41
    Location:
    Central London
    Ratings:
    +17
    Note to self: Ex TMA engineer round the corner from me!!

    How far do your servicing talents stretch, Graham? :D ;)
     
  7. GrahamMG

    GrahamMG
    Well-known Member

    Joined:
    May 8, 2004
    Messages:
    4,449
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    UK
    Ratings:
    +192
    Depends what is wrong, simple stuff only, low level fault finding and board swaps are best left to IAG..... I wouldn't wish to make a habit of it but a speaker connector is pretty basic stuff......
     
  8. dougan

    dougan
    Active Member

    Joined:
    Jan 12, 2005
    Messages:
    439
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Devon
    Ratings:
    +10
    Thanks for all your input guys!
    Graham I live in Devon, so are not just round the corner.
    Have heard from IAG, no problem with them doing the repair, but there is a 4 week turn around. Might wait untill my summer holidays and return it just before I leave.

    Regards

    Dougan
     
  9. GrahamMG

    GrahamMG
    Well-known Member

    Joined:
    May 8, 2004
    Messages:
    4,449
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    UK
    Ratings:
    +192
    :D
    I might visit the Eden project with "spanners" in boot at some stage..... Seriously if your not confident of doing this it is always sound advice to let the manufacturer do it or other approved service outlet.
     
  10. JohnDee68

    JohnDee68
    Standard Member

    Joined:
    May 28, 2005
    Messages:
    34
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Location:
    Glasgow
    Ratings:
    +0
    Dougan

    I have the same problem with my 100p Power amp, works fine but I dont unplug the phono connectors as the plugs comes out from the back.

    Did Tag give you a quote as to how much they would charge for repair of the phono connectors?.
     
  11. ariecol

    ariecol
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    wht a small world dougan? u r the man who bought my 1nt? i think u were trying to sell it in hifi choice forum innit?
     

Share This Page

Loading...