1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sweetspot/DScaler problems

Discussion in 'Desktop & Laptop Computers Forum' started by fraggle, Oct 28, 2005.

  1. fraggle

    fraggle
    Member

    Joined:
    Dec 11, 2002
    Messages:
    1,441
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Milton Keynes
    Ratings:
    +29
    Hi,

    I've build an HTPC, running MS XP MCE with all updates on it.

    The MCE side of it is working fine, couple of niggles but thats not a problem.

    What is a problem is getting DScaler to work.

    The Sweetspot card is being fed an RGB signal from Tivo/Freeview/DVD player via a quintro RBG switch box.

    I've tried DScaler 4.1.7p4, 4.1.8 and 4.1.11 (which says its 4.1.10?).

    I've tried the WDM drivers, and the BT Wincap drivers (not at the same time obviously!), and I've tried without any drivers.

    These have been downloaded from the Pixel Magic website so are the latest drivers.

    If I reboot the machine and install & run DScaler without any drivers it'll work most of the time. Unless I run MCE first, in which case it'll just give me a black screen and "the video thread did not terminate in a timely manner" error.

    If I use the WDM drivers I get a really poor picture, fuzzy, ghosting, horrible.

    If I use the BT Wincap drivers I get an image that sometimes doesn't synch properly, the colours are all mixed up, and the picture looks like the brightness is wound right down and the contrast turned right up - again unwatchable.

    Also if I use either the WDM or BT Wincap drivers, every time I try to change back from the DShow source to the Sweetspot direct source the PC locks up completely.

    Also if I do manage to get DScaler to give me a good picture, when I exit it and fire up MCE again, any live picture through MCE stutters a lot, the only way to cure this is by rebooting the machine.

    Anyone got any ideas what I can do? Apart from binning it and looking for another solution :)

    When it does work its :thumbsup: but more often than not its a big :thumbsdow as I have to hit the reset button yet again.
     
  2. fraggle

    fraggle
    Member

    Joined:
    Dec 11, 2002
    Messages:
    1,441
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Milton Keynes
    Ratings:
    +29
    Oh I also forgot that most of the time when I install DScaler it disables my Hauppage TV tuner card, so MCE just goes "whu? no tuner installed"!
     
  3. DaveP

    DaveP
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    IIRC, I had similar problems on a new PC after I had the card working fine in an earlier PC.

    In the end I got it working with, I think, no drivers, and the version of DScaler that was on the supplied CD.

    Sweetspot should appear in the list when you run DScaler.

    Dave
     
  4. fraggle

    fraggle
    Member

    Joined:
    Dec 11, 2002
    Messages:
    1,441
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Milton Keynes
    Ratings:
    +29
    Yeh, I've tried that combination. Sweetspot does appear in the list no problem, just doesn't do anything most of the time (apart from either give errors or lock the machine up)

    I've just seen that V4.1.14 is out so I'm going to d/l that and give it a whirl.

    If that doesn't get it working reasonably reliably I think I may have to sell it and look around for something else :(
     
  5. fraggle

    fraggle
    Member

    Joined:
    Dec 11, 2002
    Messages:
    1,441
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Milton Keynes
    Ratings:
    +29
    Little update :-

    Trying out 4.1.14 with no drivers
    It reliably starts up and gives me a good picture.
    It reliably shuts down.
    I've managed to get it to NOT play with the DVB-T tuner card, if it did it stopped MCE from doing whatever it was doing (including recording) - I can now have MCE in a window and DScaler in a window both running happily next to each other :)

    The one problem I have is that the PC goes into standby when DScaler is running. This is a problem, but an even bigger problem is that upon resuming from standby the DScaler window is completely black, I get the "video thread failed to exit..." error on closing DScaler, and closing it doesn't close it, the process is still in the background. Even after killing the process the machine needs rebooting to be able to use DScaler again. (I think - I'll have to do more checking to verify this last bit as I only just noticed the DScaler task was still in memory after I closed the main window)

    So the last problem I have to fix is how to stop the PC going into standby when DScaler is running? Is there some hack for Windows XP where I can name a process/program and XP will monitor for that program and not go into standby if it is running?

    That'd be the last piece of the puzzle and I'd be a happy man :) :) :)
     

Share This Page

Loading...