SVS-SB1000 Pro makes high pitch coil whine

p28nay

Active Member
Hi, I just purchased an SVS-SB1000 Pro subwoofer from one of the forum sponsors which arrived today. However, as soon as I unboxed it and connected it up I can hear a really loud high pitch electrical noise from the sub. It almost sounds like it's some sort of coil whine which is very noticeable when the room is quiet as it's just constant which makes it annoying.

The sub is connected to a power conditioner and I have also tried it in a different room in the house with nothing connected and still the same issue. Has anyone else had this issue or is there anything else someone can suggest for me please? I'll leave it on overnight and see if it calms down by the morning and if not I'll contact the seller and arrange a return which would be a shame as it's a good sounding sub.

Thanks
 

AmericanAudio

Well-known Member
AVForums Sponsor
If it is faulty and in the UK, it should be swapped over for you without issue (can't comment for the none UK market place)

Us dealers and the UK SVS Warehouse get great support from SVS directly to sort issues like this straight way.

No need to worry.
 

p28nay

Active Member
If it is faulty and in the UK, it should be swapped over for you without issue (can't comment for the none UK market place)

Us dealers and the UK SVS Warehouse get great support from SVS directly to sort issues like this straight way.

No need to worry.

Unfortunately not the best response from SVS. They are not willing to replace the unit with a new one. The only option they are giving me is to ship out a replacement sub amplifier that I have to replace where there is an eta 3-4 weeks lead time :(
 

AmericanAudio

Well-known Member
AVForums Sponsor
That is possibly because they don't have many available, stock is properly screwed world wide right now? Have you spoken to the store you bought from?
 

stevoknevo

Active Member
Unfortunately not the best response from SVS. They are not willing to replace the unit with a new one. The only option they are giving me is to ship out a replacement sub amplifier that I have to replace where there is an eta 3-4 weeks lead time :(
Speak to the retailer, not SVS, as it's up to them to make this right and they can take it up with SVS on their own behalf as why have a middleman otherwise - I think that's a shocking response from SVS, you need to wait 3-4 weeks for a new amp plate AND fit it yourself, GTFOOH! (not that it's difficult to replace the amp, but why should you have to on a brand new item?)

The Consumer Rights act has you covered on this, either request a replacement or reject it as faulty for a refund - the SVS rep you spoke with will likely be in the US and be unaware of how things work in the UK (for now at least!)
 

p28nay

Active Member
Speak to the retailer, not SVS, as it's up to them to make this right and they can take it up with SVS on their own behalf as why have a middleman otherwise - I think that's a shocking response from SVS, you need to wait 3-4 weeks for a new amp plate AND fit it yourself, GTFOOH! (not that it's difficult to replace the amp, but why should you have to on a brand new item?)

The Consumer Rights act has you covered on this, either request a replacement or reject it as faulty for a refund - the SVS rep you spoke with will likely be in the US and be unaware of how things work in the UK (for now at least!)

Correct, those were my thoughts exactly. It was Ed Mullen from SVS who gave me that response. There doesn't seem to be a way to get in touch with their UK support, it's all based in the US.

I've contacted the dealer I purchased it from and they will arrange a swap out when they get more stock of them in the next week or so, fingers crossed. Thought it might have been quicker going directly to SVS but no.
 

p28nay

Active Member
Been in touch with the dealer and they have confirmed they will replace the sub in around 10 days time :) Happy with that solution.
 

p28nay

Active Member
Just to wrap up this thread with what I found with the SB 1000 Pro. I managed to get the unit replaced and the replacement was no different. Still made the same high freq noise just like the previous unit. The dealer was really good and arranged a return and I got a refund for it. There must be some design flaw with how that model is manufactured for it to be making that noise.

I then decided to go for the BK P12-300SB-PR and that was even worse. Different type of noise this time, it was more like a constant buzzing noise. Tried an IFI DC blocker on that and that didn't make any difference so that has gone back for a refund.

Last resort I found a good deal on an ex-demo SVS SB2000 Pro and that works like a charm. No buzzing or any weird noises and it's one hell of a performer which I am really pleased with. It was a bit more out of my budget but think the extra couple hundred spent on it will be worthwhile.
 
Last edited:

p28nay

Active Member
but your signature says SB2000 pro not PB, so one probably a typo?

Yes, sorry, the PB is a typo. Should have written SB2000 Pro. Just edited it.
 

Xexets

Active Member
So glad I found this thread! I am at the second P12 300 PR - both with audible buzzing noise from transformer, regardless of DC blocker. Was about to get an SB1000 pro, but after reading this... will go for the 2000 straight away. Can I ask which retailer you got it from?
Thanks!
 

p28nay

Active Member
So glad I found this thread! I am at the second P12 300 PR - both with audible buzzing noise from transformer, regardless of DC blocker. Was about to get an SB1000 pro, but after reading this... will go for the 2000 straight away. Can I ask which retailer you got it from?
Thanks!

Don't think you will have any issues with the SB2000 Pro. I've had it a good few weeks now and am absolutely thrilled with it. SVS customer service and warranty is very good as well, you get 5 years.

I purchased mines from American Audio Company - North American HiFi Gear here in the UK They are one of the forums sponsors.
 

Gasp3621

Distinguished Member
Thank you! Unfortunately they don't have it in gloss white, which is what I am after!

Sure they have, but it will cost extra! You can talk with Chris @AmericanAudio about AVF members discount if possible.

 

Xexets

Active Member
Sure they have, but it will cost extra! You can talk with Chris @AmericanAudio about AVF members discount if possible.

I've been cheeky and asked by DM ;-)
 

Xexets

Active Member
How is that company still in business? I thought it went down long time ago. Anyway you will get price matching usually for the lowest market price, just mention it for AA`s Chris. He will probably see my tagging and respond here soon.
All right I guess that answers my question... ;-) In the meantime I arranged with Tom collection of the P12... very sad to see it go but the buzzing is driving me nuts.
 

p28nay

Active Member
All right I guess that answers my question... ;-) In the meantime I arranged with Tom collection of the P12... very sad to see it go but the buzzing is driving me nuts.

Yeah, I was sad to see my P12 go back too. It sounded great and went down really low thanks to the passive radiator. But the SVS 2000 is ace as well and the form factor is nicer too.
 

Xexets

Active Member
@p28nay : just plugged in the SB2000 pro. Transformer is dead silent (but the unit is working! ;-) )
Will test it thoroughly later today, but definitely a completely different story compared to the buzzing of the P12...
 

p28nay

Active Member
@p28nay : just plugged in the SB2000 pro. Transformer is dead silent (but the unit is working! ;-) )
Will test it thoroughly later today, but definitely a completely different story compared to the buzzing of the P12...

That's great to hear! You've certainly had the same experience as me then. You shouldn't hear any weird buzzing now.

As you use Audyssey re-calibrate everything and the sub should sound sweet. I use the sb2000 with an anti-mode box as my Sony DN1080 AVR doesn't do any EQ for the sub. On mines, I turn off the low pass filter and let my AVR handle the crossover.

Now you can enjoy testing your favourite movies. The opening of Edge of Tomorrow is great to test. 30 seconds in and you can hear how low your sub will go.
 

AmericanAudio

Well-known Member
AVForums Sponsor
@p28nay : just plugged in the SB2000 pro. Transformer is dead silent (but the unit is working! ;-) )
Will test it thoroughly later today, but definitely a completely different story compared to the buzzing of the P12...
Great News Xexets.

Now its time to sit down and enjoy it over the weekend.
 

The latest video from AVForums

Sony Bravia XR A80J OLED TV Review
Subscribe to our YouTube channel

Latest News

Audioengine launches compact S6 powered subwoofer
  • By Andy Bassett
  • Published
What's new on Sky and NOW UK for February 2022
  • By Andy Bassett
  • Published
Piega launches Ace Wireless speakers
  • By Andy Bassett
  • Published
M&K Sound launches V+ Series subwoofers
  • By Andy Bassett
  • Published
Denon launches DHT-S517 Dolby Atmos soundbar
  • By Andy Bassett
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom