1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SVS PB2 plus / Behringer FD assistance

Discussion in 'Subwoofers' started by MickB, Jun 13, 2004.

  1. MickB

    MickB
    Active Member

    Joined:
    May 15, 2004
    Messages:
    502
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Hanslope,Bucks
    Ratings:
    +30
    Hi,
    I've recently added these to my system, and the results are fantastic!

    However, I find that if the sub is left on, and you then switch on the BFD, you get a huge THUMP from the sub, even though there is no signal present (ie nothing playing)?

    The connections are unbalanced, just normal sub cable from processor to BFD, then BFD to sub.
    Surely I don't have to leave the BFD on permanently.

    Any ideas?

    :lease:
     
  2. ShinObiWAN

    ShinObiWAN
    Banned

    Joined:
    Oct 2, 2003
    Messages:
    748
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Location:
    Derbyshire
    Ratings:
    +0
    As far as I'm aware the only solutions to this problem is either leave the BFD on or switch it on before the sub.

    I leave mine on and its current draw is negligible.

    Its a small price to pay for the difference it make to the sound.
     
  3. Smurfin

    Smurfin
    Distinguished Member

    Joined:
    Aug 13, 2002
    Messages:
    21,154
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +4,329
    I always left my BFD on, due to that very reason. That thump is not very nice at all.....
     

Share This Page

Loading...