Suspension issue?

dts_boy

Well-known Member
We have a BMW X3 30d which in general has been a great family car. In the main, its my wife's car so I don't really drive it that much. However, I have recently noticed It has a slightly vague feel to the suspension and feels like it wants to pull to left slightly (a bit like when you drive on tramlines). It doesn't pull/swerve under breaking or anything but I feel it needs looking at. I'm struggling to get it booked anywhere (who's gonna answer the phone on Xmas Eve?!) so anyone got any thoughts/opinions or anything I can take a look at myself?
 

mjn

Distinguished Member
Usually tyres. As above, check condition and pressures of the tyres. Could also be the alignment if a pot hole has been hit hard.
 

noiseboy72

Distinguished Member
Tyre pressures, tracking and worn suspension bushes - in that order! The X3 is known to start to feel a bit top heavy when things start to wear. I drove one that felt like it was tipping from one side to the other over a knife edge during sharp changes of direction. This was due to worn bushes and the owner replaced them all, fixing the issue.
 

dts_boy

Well-known Member
Thanks for the replies, sorry I didn't get any notification. Tyre pressures seem ok, I would guess bushes as well but will try and get it on a ramp and get it checked!
 

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom