Surround sound windows 10 help

SnakePlissken006

Novice Member
Hi, I recently got a gaming and I've been having the worst time trying to sort out my surround sound system with it. I'm using a 3080ti card with a Sony x900h tv and sony str-dn1080 receiver. Both the receiver and tv support hdmi 2.1 and have them activated. I'm also using hdmi 2.1 cables. I have both hdmi 2.1 slots in use on tv. My receiver is connected using earc straight to my tv and my gpu is connected to the other hdmi 2.1 on tv. Earc is activated on both receiver and tv. The first problem is whenever I start pc it won't pick up and audio. It shows that audio is working with the green bar when I test but I can hear no sound. The only way I can sort this is by switching to tv speakers then back to audio system on the tv. The apps on my tv don't have this problem plays as soon as I turn tv on. I have dolby atmos activated on my pc and it worked on gears 5 but for some reason some games play stereo and won't recognise I have surround sound set up. I had a look on properties for my sound device and for some reason it only supports 16 bit bit depths, 48.0khz sample rates and max format is 16 bit, 48000z dvd quality and won't show any other options. I tried setting speakers to normal 5.1 but the options were the same and very low sound quality. Also when I test speakers on 5.1 it works fine but atmos it doesn't. Some speakers may activate very quietly when I try to sound test the speakers on it. On my playback devices I also have 3 options for nvidia output, they're all the same and says not plugged in. The one I use is sony tv, nvidia high definition audio. If also tried changing about the tv and receiver settings to different formats but nothing. My switch and ps5 worked perfect on arc so I'm sure it's something to do with windows. Sorry for the long thread haha but I'm all out of ideas and really need some help I've wasted so much of my time trying to sort this.
 

Delvey

Distinguished Member
I had this same issue and never found a solution. I believe its a handshake issue between the PC and the TV, with the TV not letting the PC know it can accept 5.1.
Plugging directly into the receiver works fine I presume?
 

SnakePlissken006

Novice Member
I had this same issue and never found a solution. I believe its a handshake issue between the PC and the TV, with the TV not letting the PC know it can accept 5.1.
Plugging directly into the receiver works fine I presume?
Well this sucks. Wish I knew pc couldn't work with earc and arc before forking out so much money to build one. Can't really plug it straight into receiver as gpu only had one hdmi slot. Could use optical but then I'd be missing out on atmos and good quality sound.
 

next010

Distinguished Member
Well this sucks. Wish I knew pc couldn't work with earc and arc before forking out so much money to build one. Can't really plug it straight into receiver as gpu only had one hdmi slot. Could use optical but then I'd be missing out on atmos and good quality sound.

1) Get a Displayport to HDMI cable.
2) Connect the DP output of the GPU to the HDMI input of the receiver.
3) Set the DP/receiver output as default audio output in Windows.

For this to work you must be able to manually change the audio output on the DN1080, some CEC/ARC systems wont let you do this and will auto revert to 'TV' as they see your using the TV HDMI input for video.

So check that you can cycle through the audio inputs on the DN1080 while using your PC, if it doesn't auto switch back you should be good with the above.


A PC's native output is PCM (uncompressed digital audio) in stereo or multi-channel form, it has no native capability to output Dolby audio, that must be done via third party software (Dolby Access app).

Secondly the PC must scan the TV EDID for what audio it supports, this is often unreliable on windows.

Also be aware the Sony X900H has bugged 120hz PCM 7.1 eARC (if still unfixed) which can cause problems particularly as PC uses PCM by default.


Other options.

Make sure your TV is configured for eARC on Sony this is typically
Audio Output in the Display & Sound settings menu,
eARC to 'Auto'
Digital Audio Out to 'Auto 1'
Passthrough to 'Auto'

If it still cannot see the Dolby Digital Plus you can use CRU to add it to the windows EDID.
1) edit extension blocks
2) edit audio formats
3) add E-AC-3 (7.1)
4) click ok then ok to close
5) edit speaker setup select 7.1 preset
6) click ok till program closes then run restart64 to apply changes

Whether that triggers the Dolby Access app into acknowledging it I'm unsure but what you can do is plug PC direct into the DN1080 run CRU and make note of settings it detects for Dolby Atmos (E-AC3, LPCM, TrueHD) then copy those settings into the CRU when connected to the TV directly and hope it works.

The X900H has a blurred 120hz output, no HDMI-VRR, buggy eARC PCM at 120hz, maybe this TV is not so good for PC 120hz output and connecting directly to the DN1080 for 4K 60hz HDR is the way to go.
 

sykotik

Distinguished Member
There is a way - how ever im not sure if dolby Atmos will work , my amp at the time didn't have atmos
you need a display port to HDMI adaptor ( loads on Amazon)
so what i did was
GPU > TV ( HDMI cable using the HDMI port on the GPU )
GPU > AMP ( DP adaptor -HDMI cable ,using the DP port on the GPU )

I then could get Turehd and DTS-HD master ( using software call mediaportal - i used this to watch MKV files on my NAS drives)

but the down side to this is , it's like have 2 monitors running at the same time , and every now again i would open something up and the window will open and the amp's display ( so i would have change HDMI inputs on the TV , find the open file/app and drag it back over to the main display

Do games have Dobly atmos ?

this could be an option for you :)
 

SnakePlissken006

Novice Member
1) Get a Displayport to HDMI cable.
2) Connect the DP output of the GPU to the HDMI input of the receiver.
3) Set the DP/receiver output as default audio output in Windows.

For this to work you must be able to manually change the audio output on the DN1080, some CEC/ARC systems wont let you do this and will auto revert to 'TV' as they see your using the TV HDMI input for video.

So check that you can cycle through the audio inputs on the DN1080 while using your PC, if it doesn't auto switch back you should be good with the above.


A PC's native output is PCM (uncompressed digital audio) in stereo or multi-channel form, it has no native capability to output Dolby audio, that must be done via third party software (Dolby Access app).

Secondly the PC must scan the TV EDID for what audio it supports, this is often unreliable on windows.

Also be aware the Sony X900H has bugged 120hz PCM 7.1 eARC (if still unfixed) which can cause problems particularly as PC uses PCM by default.


Other options.

Make sure your TV is configured for eARC on Sony this is typically
Audio Output in the Display & Sound settings menu,
eARC to 'Auto'
Digital Audio Out to 'Auto 1'
Passthrough to 'Auto'

If it still cannot see the Dolby Digital Plus you can use CRU to add it to the windows EDID.
1) edit extension blocks
2) edit audio formats
3) add E-AC-3 (7.1)
4) click ok then ok to close
5) edit speaker setup select 7.1 preset
6) click ok till program closes then run restart64 to apply changes

Whether that triggers the Dolby Access app into acknowledging it I'm unsure but what you can do is plug PC direct into the DN1080 run CRU and make note of settings it detects for Dolby Atmos (E-AC3, LPCM, TrueHD) then copy those settings into the CRU when connected to the TV directly and hope it works.

The X900H has a blurred 120hz output, no HDMI-VRR, buggy eARC PCM at 120hz, maybe this TV is not so good for PC 120hz output and connecting directly to the DN1080 for 4K 60hz HDR is the way to go.
Ok this is a start I used cru, went on audio format and ticked all the boxes for sample rates and bit depths for all audio formats. They were all stuck at 48.0 kHz and 16 bit depths. Now this is showing on my properties in windows sound settings. Still no sound after restarting my computer. But I'll try more things. I forgot to mention that I had no issues with my 3070. I upgraded to a 3080ti and then the problems started. I have reinstalled windows since and redownloaded gpu drivers. All my tv settings and receiver settings are fine I've spent hours messing round with them. It's 5.1 speakers I'm using and the front speakers are atmos with top speakers added in, receiver had a phantom speaker setting. It's weird as gears 5 works amazing in atmos it even says on receiver its playing atmos. Yeah I've heard 120hz is buggy, I'm not interested in that anyway 60fps is plenty for me. I have put my max fps to 60fps on nvidia settings.
 

next010

Distinguished Member
Yeah I've heard 120hz is buggy, I'm not interested in that anyway 60fps is plenty for me. I have put my max fps to 60fps on nvidia settings.

Then the easiest thing to do is connect directly to the DN1080.

Set your output in Nvidia control panel as 12-bit YCC 422 at 4K 60hz, turn on HDR in win control panel (otherwise it will output 8-bit HDR) and you should get the best audio in combo with optimal HDR.
 

SnakePlissken006

Novice Member
Then the easiest thing to do is connect directly to the DN1080.

Set your output in Nvidia control panel as 12-bit YCC 422 at 4K 60hz, turn on HDR in win control panel (otherwise it will output 8-bit HDR) and you should get the best audio in combo with optimal HDR.
Passing video through receiver will cause huge input lag though.
 

next010

Distinguished Member
Passing video through receiver will cause huge input lag though.

Even with game mode on the TV ?

Sony DN1080 has one of its HDMI inputs labelled as game (to the left of video 1), though that shouldn't make any difference all inputs should normally be the same.

Try dropping it to 10-bit 420 and see if that changes lag wise and the DN1080 is set to enhanced mode, the manual shows using a PS4 with it so the DN1080 must be low latency.
 

SnakePlissken006

Novice Member
Even with game mode on the TV ?

Sony DN1080 has one of its HDMI inputs labelled as game (to the left of video 1), though that shouldn't make any difference all inputs should normally be the same.

Try dropping it to 10-bit 420 and see if that changes lag wise and the DN1080 is set to enhanced mode, the manual shows using a PS4 with it so the DN1080 must be low latency.
Ok I'll give it a try. I've managed to get it working a bit. Just set it to 5.1 after messing round with cru. When I go on sound test though and test rl and rr speakers they both pkay out of the two rear speakers when testing either left or right. So weird how this issue only occurred after upgrading gpu. Before I had atmos enabled and all games sounded great on it even old games and games on emulators. Sound still won't play straight away though when starting pc have to switch back to normal tv speakers then sound system again. This never happened on my 3070 either. I'm guessing it might be a driver for the 3080ti? Don't know why it would be different than the 3070 though but it worked fine on that. Hopefully windows 11 is a bit better for setting up surround sound.
 
Last edited:

Delvey

Distinguished Member
Did you resolve this? I've got my mining PC connected to the TV and then TV via ARC to AMP. Can't output dolby digital. Works fine if I plug it straight into the AMP. This is a Samsung TV, Nvidia 3060Ti
 

The latest video from AVForums

AVForums Movies Podcast: Which is the best decade for horror movies?
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom