Suggestions for AVI/AVR to partner B&W 705s

Discussion in 'AV Receivers & Amplifiers' started by chrisgeary, Apr 26, 2007.

  1. chrisgeary

    chrisgeary
    Well-known Member

    Joined:
    Jul 23, 2003
    Messages:
    2,787
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Newbury
    Ratings:
    +255
    All,

    My current kit consists of:
    Meridian 561M Digital Surround Pre-amp
    3 Meridian 505 Power Amps
    NAD 3240 driving the rears.

    This is a 5 box solution which is taking up a lot of space (and money). I want to downgrade to a 1 or 2 box system. I am thinking of retaining a Meridian power amp to drive the 705s, probably a 556. I am hoping you can offer me some suggestions for an integrated AV amp or receiver. I am 70/30 in favour of music. The Meridian 561 is going to be missed as it is top notch for 2 channel so I'm looking for something that is going to sound good in that department. My shortlist so far is:

    Arcam AVR-300

    That's it. Anything else that I should consider?
    Pre-outs are a must.
    All sources will be connected digitally so DACs must be top notch. I'm not bothered about bells and whistles - just really good SQ.

    thx

    Chris
     
  2. richimlong

    richimlong
    Active Member

    Joined:
    Aug 23, 2006
    Messages:
    96
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +3
    The Arcam AVR350?

    The pre amp stage of the 350 has been improved compared to the 300, and when I auditioned I found the 350 to be a noticable improvement over the 300, wrt sound quality.

    Im sure the guys over at the Arcam forum will be helpful:
    http://www.avforums.com/forums/forumdisplay.php?f=119

    Rich
     
  3. chrisgeary

    chrisgeary
    Well-known Member

    Joined:
    Jul 23, 2003
    Messages:
    2,787
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Newbury
    Ratings:
    +255
    thanks for that.. any other suggestions?
     
  4. Knyght_byte

    Knyght_byte
    Well-known Member

    Joined:
    Nov 4, 2004
    Messages:
    11,033
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Harrow, NW London
    Ratings:
    +600
    not 100% on the pre-outs for all channels, but check out Primares SPA21, sound quality is staggering for an AV amp....however it is VERY limited in functionality.....check primares site to see if its close to being suitable...
     
  5. chrisgeary

    chrisgeary
    Well-known Member

    Joined:
    Jul 23, 2003
    Messages:
    2,787
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Newbury
    Ratings:
    +255
    The SPA21 is too much money... but what about a s/h SPA20?
     
  6. chrisgeary

    chrisgeary
    Well-known Member

    Joined:
    Jul 23, 2003
    Messages:
    2,787
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Newbury
    Ratings:
    +255
    I went for an SPA20 on ebay a few weeks ago. Its very impressive. Replacing 5 boxes with one, space-wise its a winner. It looks great too! So far:

    Pros:
    - unlike my Meridian processor, it sounds the same at any volume (my 561 would sound decidely dull at lower volumes)
    - It syncs to digital signals without digital hash - a problem that seems to exist with Meridian for some reason.
    - It has no relays! I didn't know how annoying they were until they were gone!
    - It is detailed but doesn't seem harsh - I've not really tried it out loud yet.
    - The setup is easy - no more laptop and uploading stuff whenever I need to make a change.

    Cons:
    - not many so far. If I were being picky, I'd say the Meridian was a tad smoother. The SPA20 is a little clinical. The treble seems a little less gritty, but perhaps a little too sparkly for my tastes. I dont think this is something that is going to bother me greatly though. If I could afford a G95, I'd buy one.
    - the on screen display has failed a few times - a power cycle seems to sort it out.
    - it was unable to lock on to DVE once, a power cycle sorted it.
    - it gives out the odd crack now and then, not often, a little like static.

    I've asked Primare if there are any firmware updates that perhaps address the above issues - none of which are serious at all. Its early days, but I think this is a great amp that I'll keep for quite some time. I know that I will secretly be pining for a 568.2 and 5ch power amp combo one day :)
     

Share This Page

Loading...