1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Subtitle problems w/ Shaun of the Dead

Discussion in 'Movie Forum' started by DocShock, Sep 17, 2004.

  1. DocShock

    DocShock
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I just recieved a Region 2 Shaunn of the Dead DVD - the movie was awesome, but for some reason the subtitles will not turn off. I didn't turn them on, but they are always there, no matter what I do.

    I have a Cyberhome DVD which I made regionless and have watched Region 4 and Region 1 DVDs without this problem. Shaun of the Dead is my first region 2, but I didn't expect that to happen.

    Anyone have any advice or know how to overcome this problem?

    Thanks so much!
     
  2. chic

    chic
    Well-known Member

    Joined:
    Jul 1, 2001
    Messages:
    5,976
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    glasgow
    Ratings:
    +871
    quite a few people have had similar problems with this disc with many different players, it played ok on my player, there is nothing you can do about it, try it in another player
     
  3. DocShock

    DocShock
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    What type of DVD player do you have? Is it regionless? What's the best regionless DVD player on the market - might be an investment I'd like to make. Thanks for the reply!
     
  4. chic

    chic
    Well-known Member

    Joined:
    Jul 1, 2001
    Messages:
    5,976
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    glasgow
    Ratings:
    +871
    i have a toshiba 510 which has been made multiregion,normally the more expense the player the more reliable at the less problems you should have with it, i paid £300 for my tosh 2 years ago and i am well pleased with it i have only had one disc in all that time which gave me problems.My first player was a chepo grundig and that gave me no end of problems
     
  5. nwgarratt

    nwgarratt
    Distinguished Member

    Joined:
    May 5, 2002
    Messages:
    26,440
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,871
    It played fine in my Sony NS900 adn Ebench KH777. It showed the subtitles on the Pioneer DV350.
     
  6. girliedrinker

    girliedrinker
    Standard Member

    Joined:
    Jul 11, 2003
    Messages:
    78
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Location:
    London
    Ratings:
    +0
    Admittedly it's a bit of a weird disc for me - can't fast forward, rewind or pause. I've also had the subtitles problem but cured it by pressing "Subtitles Off" on the remote whilst in the main menu and starting the film again.
     
  7. Pug72

    Pug72
    Well-known Member

    Joined:
    May 10, 2003
    Messages:
    1,992
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Hereford
    Ratings:
    +277
    I had to select subtitle 6 to have none onscreen.
     
  8. DocShock

    DocShock
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I'm going to play around with it tonight and see if I can figure out an option to shut the subtitles off - I doubt it will work thought, but hell, it's worth a try. Thanks for the suggestions!
     
  9. dts_boy

    dts_boy
    Member

    Joined:
    Nov 26, 2001
    Messages:
    2,544
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Manchester suburbs...
    Ratings:
    +145
    i have had this problem tonight on my arcam dv27. i had turn to off subtitles and then alos the commentries in the setup menus on the film then it played just fine!
     
  10. Mr.D

    Mr.D
    Well-known Member

    Joined:
    Jul 14, 2000
    Messages:
    11,061
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    133
    Ratings:
    +1,149
    I had exactly the same problem on my HTPC using Theatertek and the only way to switch them off was to go into the subtitle menu on the dvd menu : switching off internally to TT had no effect.

    Some of the extras had exactly the same issue.

    I'm inclined to say its a disc problem judging by the amount of people experiencing the problem.

    Rubbish UK mastering houses again most likely.
     

Share This Page

Loading...