1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sub Thread NR 3993940...

Discussion in 'Subwoofers' started by jhjerpe, Jun 18, 2003.

  1. jhjerpe

    jhjerpe
    Active Member

    Joined:
    Mar 1, 2003
    Messages:
    697
    Products Owned:
    0
    Products Wanted:
    2
    Trophy Points:
    28
    Location:
    North London
    Ratings:
    +64
    My REL left home last night... :( hope it has a happy life. It's to be replaced with a B&W ASW675 because I think they look great and would really match the rest of my set-up visually...

    I hand over the cash in a couple of hours but I am getting nervous, any one got anything good or bad to say about the B&W sub? I've read some good reviews but thats not always a great source of 'accurate info'!

    Also - if someone owns the sub... can you use the LF and HF connectors at the same time like the REL subs?
     
  2. Ian J

    Ian J
    Banned

    Joined:
    Aug 6, 2001
    Messages:
    25,528
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +4,906
    I don't think that you will be unhappy. If you want to gen up on the sub before you collect it, there is a manual available online here
     
  3. deckard

    deckard
    Standard Member

    Joined:
    Dec 4, 2002
    Messages:
    425
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Location:
    leicester
    Ratings:
    +0
    IIRC when I looked at it, it only has low level connections...:confused:
     
  4. jhjerpe

    jhjerpe
    Active Member

    Joined:
    Mar 1, 2003
    Messages:
    697
    Products Owned:
    0
    Products Wanted:
    2
    Trophy Points:
    28
    Location:
    North London
    Ratings:
    +64
    Thanks for the link, having a quick read through the manual it's not clear if you can use the LF & HF at the same time......

    My ideal set-up is using the HF for L&R from my Arcam A85 and then the LF from my Pioneer 2011. I'll get on the phone I think and quiz B&W!
     
  5. ReTrO

    ReTrO
    Active Member

    Joined:
    Jul 12, 2000
    Messages:
    3,499
    Products Owned:
    0
    Products Wanted:
    2
    Trophy Points:
    71
    Location:
    High Wycombe, Bucks, UK
    Ratings:
    +59
    No high speaker level inputs, low line level only.
     
  6. jhjerpe

    jhjerpe
    Active Member

    Joined:
    Mar 1, 2003
    Messages:
    697
    Products Owned:
    0
    Products Wanted:
    2
    Trophy Points:
    28
    Location:
    North London
    Ratings:
    +64
    Looking at the manual again... should learn to read. As mentioned by ReTrO there is no HF input.... so I take it from this you can't have both the A85 and the 2011 hooked up at the same time.

    No big worries as I mainly use the sub for movies.

    Just got a call, the ASW arrives in the morning... :clap:
     
  7. wilber

    wilber
    Active Member

    Joined:
    Sep 29, 2002
    Messages:
    1,970
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Ratings:
    +30
    I'd have thought your 603s would chug out enough bass on their own anyway!

    edit for 2 ch that is
     
  8. jhjerpe

    jhjerpe
    Active Member

    Joined:
    Mar 1, 2003
    Messages:
    697
    Products Owned:
    0
    Products Wanted:
    2
    Trophy Points:
    28
    Location:
    North London
    Ratings:
    +64
    Funny you should say that..... gave DSOTM on SACD a quick spin without the sub last night and it did sound great with just the 603s! So I am not to concerned... :)
     
  9. MuFu

    MuFu
    Active Member

    Joined:
    Jul 24, 2002
    Messages:
    1,191
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    41
    Location:
    NW2, London
    Ratings:
    +4
    Good! Nice sub - a better performer than the Q200E, from what I heard at a couple of demos. Certainly in terms of sheer output. :)

    What REL did you have before, BTW?

    MuFu.
     
  10. jhjerpe

    jhjerpe
    Active Member

    Joined:
    Mar 1, 2003
    Messages:
    697
    Products Owned:
    0
    Products Wanted:
    2
    Trophy Points:
    28
    Location:
    North London
    Ratings:
    +64
    I had a Q200E which I thought was great, so looking forwards to seeing how the B&W performs in comparison.... have to work late tmr which is typical when new toys arrive!
     
  11. jhjerpe

    jhjerpe
    Active Member

    Joined:
    Mar 1, 2003
    Messages:
    697
    Products Owned:
    0
    Products Wanted:
    2
    Trophy Points:
    28
    Location:
    North London
    Ratings:
    +64
    The B&W has now arrived, and a quick and dirty install done, first impressions are good!
     

Share This Page

Loading...