1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sub hum

Discussion in 'Subwoofers' started by ManGina, Mar 23, 2005.

  1. ManGina

    ManGina
    Active Member

    Joined:
    Dec 14, 2004
    Messages:
    366
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Ratings:
    +22
    Is it normal for a sub to hum/buzz very slightly when plugged in?
    Even when on standby and cable not connected to the amp?
    Or have I got a faulty canton 250sc? :(
    Please help..... :rolleyes:
     
  2. Ian J

    Ian J
    Banned

    Joined:
    Aug 6, 2001
    Messages:
    25,529
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +4,906
    Try using the forum search facility and searching the subwoofer forum for "sub hum" as you will find quite a few threads.
     
  3. eviljohn2

    eviljohn2
    Well-known Member

    Joined:
    Jul 8, 2002
    Messages:
    7,529
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Near London.
    Ratings:
    +208
    Humming subs are quite a usual problem. The sub should hum very quietly when not in use but turned on as should your main speakers when your amplifier is turned on, this is generally related to the noise floor of the amplifier circuits (and the sensitivity of your speakers, and local conditions and all sorts of other things).

    I'm not familiar with the Canton sub but if it seems like it's humming more than it should then you could well have a faulty sub since removing connections should solve any ground loop trouble you may have. :)
     
  4. SillySausage

    SillySausage
    Active Member

    Joined:
    Jul 10, 2004
    Messages:
    576
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Leicester
    Ratings:
    +14
    How are you connecting the sub.

    I had this problem with my XLS200.

    When the amps is turned off, but the sub left on, their is a pronounced hum from the sub. This is apparently due to the switching and impedance qualities of the amp outputs or something.

    I have an email from BK explaining this somewhere, but if the hum is more intense with the amp off then this could be your problem

    hth

    Adam.
     
  5. ManGina

    ManGina
    Active Member

    Joined:
    Dec 14, 2004
    Messages:
    366
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Ratings:
    +22
    I have to say it's a quiet hum and it happens when in I plug in / power up - make's no difference if cable ( mark grant sub cable) is connected or not. I haven't tried earthing the sub and it doesn't detract from enjoyment of movies etc as it is so quiet. I think it just may be a characteristic of a sub and as such I can live with it ( until one of you says that unless faulty it should be silent) :suicide:
    :rotfl: :rotfl: :rotfl:
     

Share This Page

Loading...