Stuck on xbmc setup

GeeZus

Well-known Member
Hi guys

Been reading up about xbmc on forum for a while and decided to try it out. I used the set up guide as found in this forum and it looks brilliant. But I've got some problems.

All my movie rips are stored on an external hard drive in a folder called 'Movies'. I added this in xbmc and it downloaded the artwork and movie info. When I went to flock through the movies I've noticed there's quite a few that are missing. The main ones missing are Fast and Furious Collection, Harry Potter 1-6, Lord of the Rings Trilogy. These movies are stored like this: Movies/Lord of the Rings/Lord of the Rings 1,etc.

Another problem I've got is I have both bluray and DVD rips on my hard drive of the same movies. When I got in to xbmc and right click on the DVD rip and select 'Remove from Library' it does so but the next time I update my library they all get added back again. I dont want to delete the movies of the hard drive so was hoping there was some easier option

Thanks in Advance
 

joeydrunk

Novice Member
GeeZus said:
Hi guys

Been reading up about xbmc on forum for a while and decided to try it out. I used the set up guide as found in this forum and it looks brilliant. But I've got some problems.

All my movie rips are stored on an external hard drive in a folder called 'Movies'. I added this in xbmc and it downloaded the artwork and movie info. When I went to flock through the movies I've noticed there's quite a few that are missing. The main ones missing are Fast and Furious Collection, Harry Potter 1-6, Lord of the Rings Trilogy. These movies are stored like this: Movies/Lord of the Rings/Lord of the Rings 1,etc.

Another problem I've got is I have both bluray and DVD rips on my hard drive of the same movies. When I got in to xbmc and right click on the DVD rip and select 'Remove from Library' it does so but the next time I update my library they all get added back again. I dont want to delete the movies of the hard drive so was hoping there was some easier option

Thanks in Advance
When you select add source don't click "use folder names for lookup" but do click scan recursively. Just remove all moves from library first, then clean library then if there are certain movies on your hard drive you don't want scanned into xbmc, then put them into s desperate folder and name it. Then add your sources and leave the folder out that you moved those movies to, then select scan recursively and do the other first step, them finish ul and when your done scan for new content. You should be all good to go!
 

GeeZus

Well-known Member
Just did what you suggested. Cleared library, moved movies with copies to another folder and added the movies folder back again. It's working now but with some of my movies (downloads) it shows the movie(with info like 720p 116 minutes, etc) but then shows another one with no info that does nothing when clicked. I've gone through the library and removed the duds but was wondering I'm currently in the process of ripping about another 10 blurays and want to add them to the same Movies folder in xmbc. Usually I edit source and add the movie folders and let it update but this updates all the movies info.

Hope I've explained properly

Thanks
 

joeydrunk

Novice Member
GeeZus said:
Just did what you suggested. Cleared library, moved movies with copies to another folder and added the movies folder back again. It's working now but with some of my movies (downloads) it shows the movie(with info like 720p 116 minutes, etc) but then shows another one with no info that does nothing when clicked. I've gone through the library and removed the duds but was wondering I'm currently in the process of ripping about another 10 blurays and want to add them to the same Movies folder in xmbc. Usually I edit source and add the movie folders and let it update but this updates all the movies info.

Hope I've explained properly

Thanks
I'm not sure if I understand you correctly but a couple things I can think of:

If it shows more than one movie, do you have like 2 parts to a movie in a file? If you dont have the named something like .cd1 and .cd2 in the same folder it won't know to connect them and think its two movies in a folder.

Another thing is that when you cleared the library the movie didn't leave and when you added it again its in there and you have one real copy and one that's not there anymore.

Or if you moved it or renamed it and scanned it again it will be in there twice, one real, one not real.

When you add new movies just put them in your file location ie: C:\movies\ or whatever and then just go to videos> files> right click on movies or press C and then scan for new content and it should add only your new movies to your xbmc movie library.

In any of the cases just click on it and it should ask if you want it deleted, if not press C on your keyboard and hit delete.

Or just get everything setup exactly how you want it and delete everything and rescan it. Also you should use IMDb scraper instead of tmdb.

Another thing, are you sure you going to your movies from the "movie" section and not the "files" section?
 

The latest video from AVForums

Panasonic HZ2000 4K OLED TV Review | The best OLED for movie viewing in 2020
Top Bottom