Strange HDMI audio issue with Sony BDP-S350 Blu Ray

Discussion in 'Blu-ray & DVD Players & Recorders' started by JOK3R, Feb 11, 2009.

  1. JOK3R

    JOK3R
    Standard Member

    Joined:
    Feb 11, 2009
    Messages:
    2
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hello everyone. This is my first post here, but I use this site pretty often as a resource, so I'm really hoping one of you guys can help me diagnose my problem.

    I recently purchased a Sony BDP-S350 Blu Ray player. I have this connected directly to my TV via HDMI. I do not have an audio recevier.

    My TV is an LG 32LC2DU 32" 720p LCD.

    My main issue I am having is that whenever I put a movie in and start it, I get no sound from the moment the disc loads. I have to press the "EZ Sound" button on my TV, which basically just cycles through various audio styles, in order for the sound to come on. If I don't do this, the sound never comes on. When it does come on, it will only come through my TV speakers. It will not come through my speakers I have connected to my TV "Audio Out" port via regular red/white A/V cables. In order to get the sound to come out of the external speakers, I have to plug them directly into the back of the Blu Ray. The speakers are actually 2 small speakers and a 6 inch subwoofer for a laptop, but they work pretty good for me for TV audio.

    My Xbox 360 and Verizon FIOS STB are also both connected to my TV via HDMI, and the sound for those come through my external speakers no problem. Although when I watched a DVD in my 360, the picture would cut off (but the sound stayed on). I would have to turn my TV off then on again for the picture to come back.

    So far, I have tried:

    -3 different HDMI cables
    -all the different ports on my TV for HDMI
    -a combination of turning the TV on and off with the Blu Ray on and off

    I only got the audio to come out of the speakers once, and it was during one of these weird combinations of turning everything on and off in a certain order. Haven't been able to do it again.

    A few of my friends with home a/v experience think it is an issue with the audio format of Blu Rays and converting it through my TV into my crappy speakers (although a regular DVD in my BD player has the same problem).

    I would think this is an issue regarding either a setting on my TV for audio (which there are practically none) or an audio setting on the BD player itself, since the picture is fine and they are both coming from the same source (HDMI).

    Hopefully someone can help me figure this out. Thank you very in advance for any info and I apologize if I sounded like an idiot through any of that. :D
     
  2. kingfats

    kingfats
    Distinguished Member

    Joined:
    Dec 29, 2006
    Messages:
    36,741
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Windsor
    Ratings:
    +9,002
    Welcome to the forum. :smashin:
    Yes that sounds like the problem,HDMI direct to the TV will give you 2ch only.Audio (HDMI) set to 2ch PCM in the player settings?
    All the best.
     
    Last edited: Feb 11, 2009
  3. JOK3R

    JOK3R
    Standard Member

    Joined:
    Feb 11, 2009
    Messages:
    2
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0

    I can set it to either Auto or 2ch PCM. I get the same problem with both settings.
     
  4. kingfats

    kingfats
    Distinguished Member

    Joined:
    Dec 29, 2006
    Messages:
    36,741
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Windsor
    Ratings:
    +9,002
    That's all the settings you can mess with i'm afraid if HDMI direct to TV.
     

Share This Page

Loading...